Ask Your Question
0

Running SAGE in the own network

asked 2013-10-22 17:28:45 -0500

Luiz Roberto Meier gravatar image

Hi!

I'm using Fedora 18 64bits where I installed the SAGE and it runs normally when I'm using localhost:8080 and with local ip of the machine: 192.168.2.51:8080 (as an example).

I checked the firewall (ipchains) , any computer can connect to 192.168.2.51 . I'm trying to run in my tablet (and several computers in a class) the SAGE in the LAN (others programs/servers are working fine).

I did a search in google and here, I'm almost 1 week trying to solve this. I can't connect in the SAGE machine/server from other computers in the local network.

1) Can someone please explain how to set it to run locally?

2) Why not include in future releases an option to automatically turn it on to an entire network and maybe outside (public)? The security issues is up to the admin of the server.

Thank you very much for the attention.

edit retag flag offensive close merge delete

4 answers

Sort by ยป oldest newest most voted
1

answered 2013-10-22 18:09:36 -0500

ppurka gravatar image

Look at the notebook options. By default it listens only to localhost. You can give the option interface="" to make it accept connections from other computers too.

edit flag offensive delete link more

Comments

Still not working.

Luiz Roberto Meier gravatar imageLuiz Roberto Meier ( 2013-10-22 18:32:47 -0500 )edit
1

answered 2013-10-23 23:38:55 -0500

Luca gravatar image

Well, I don't understand why it wouldn't work. I'm out of ideas. As an alternative, you could try setting up apache as a reverse proxy, like this

<VirtualHost *:80>
  ProxyPass / http://localhost:8080/
  ProxyPassReverse / http://localhost:8080/
</VirtualHost>

or use a different port if you have apache already running other sites (you could try using a different path on the same port, like ProxyPass /sage http://localhost:8080/, but I'm afraid it could break some links inside the notebook).

edit flag offensive delete link more

Comments

Still not working. Just can't find the local ip address with the port 8080 or 80 whatever. But all the other services (running for lan only) runs normally, I can use apache, oracle, anything. Thanks anyway.

Luiz Roberto Meier gravatar imageLuiz Roberto Meier ( 2013-10-25 02:11:07 -0500 )edit

I will try now to redo all the steps.. 1) Install of SAGE binary and test if it runs normally in localhost; 2) Reconfigure the firewall of Fedora 18; Can you please show me the line you added in your ipchains to let other from your own network access the SAGE server?

Luiz Roberto Meier gravatar imageLuiz Roberto Meier ( 2013-10-25 02:12:22 -0500 )edit
0

answered 2013-10-22 18:11:52 -0500

Shashank gravatar image

updated 2013-10-22 18:12:16 -0500

There is a sagecell server you can install on your network.

http://www.sagemath.org/eval.html

https://github.com/sagemath/sagecell

edit flag offensive delete link more

Comments

Thank you for the links but none solved my problem. I still not be able to connect from another PC or tablet to the IP of where sage server is running. I can run it via notebook() and using interface, so, in the computer where the server is I can just type http://192.168.2.101:8080/home/mysage/ (my local_ip, path + user that I created) and it works.. but if I try from any other pc/tablet I can't connect.. maybe it isn't a sage issue but my local firewall.. I got no error message from Sage, the browsers just can't find the server.

Luiz Roberto Meier gravatar imageLuiz Roberto Meier ( 2013-10-22 18:38:07 -0500 )edit

Well! I think you can't do it just by typing the ip in the url. You need to setup a sagecell server, which is different from a regular sage installation. If your computation is not resource intensive you can use the aleph server(http://aleph.sagemath.org/static/about.html), but otherwise you need to download the sagecell server from github and install it.

Shashank gravatar imageShashank ( 2013-10-22 19:40:05 -0500 )edit

I do not agree with @Shashank. Sage's server ought to work on the local network if started with `notebook(interface="")`. This looks like a network issue. Are you able to connect to any other service on your server from the tablet? Have you tried changing port with the option `port`?

Luca gravatar imageLuca ( 2013-10-23 02:22:41 -0500 )edit

Yes, @Luca , I can connect to Oracle and tested FTP and Apache. Also, I changed the 8080 to 5000, 6000, 7000 ports and still not working. I can run only in the machine , using the localhost, 192.168.2.x port 8080. I ping and the ports answers but 8080

Luiz Roberto Meier gravatar imageLuiz Roberto Meier ( 2013-10-23 03:44:02 -0500 )edit

Are you behind a router? FTP, HTTP ( Apache ) are standard ports and your router might be allowing connections to those ports. Sage, when started as `interface=""` uses a nonstandard port 8080 by default. Does it work if you change the port to 80? or 21? - these are the same ports as the FTP and HTTP servers. You need to launch the notebook like this: sage -n interface="" port=80

ppurka gravatar imageppurka ( 2013-10-23 04:33:05 -0500 )edit
0

answered 2013-10-25 03:10:07 -0500

Luiz Roberto Meier gravatar image

I figure out the problem: I had to flush my iptables and then I set it again to accept connections from 192.168.x.y only at port 8080 (I can change the default port) and worked fine. Now I can 'see' my SAGE server from my tablet, laptops and desktops. No need to install it in more than 2 computers.

Also I probed the port 8080 from outside the network and it is closed/stealth (both) , so , my guess it is secure.

Thank you all !

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-10-22 17:28:45 -0500

Seen: 1,063 times

Last updated: Oct 25 '13