Ask Your Question
1

SAGE server using VMware bundle

asked 2010-12-01 11:34:47 -0500

sandyscott gravatar image

updated 2011-02-21 08:41:04 -0500

niles gravatar image

I'd like to use SAGE notebook on windows, but access it from a browser running natively.

I've downloaded the package, and got it running in VirtualBox, turned on the network, and forwarded ports into the VM, but can't persuade SAGE to respond.

The port forwards are working: SSH works and apache responds to port 80 requests, but absolutely nothing appears to happens in response to requests on port 8000.

Can anyone help me with this?

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2010-12-04 09:56:41 -0500

sandyscott gravatar image

I fixed the problem - by default sage notebook only listen to connections from localhost, by changing setting it to listen on any interface, connections from the host machine could be accepted.

Here's how:

Create a new file /home/sage/sagenboptions.sage with the following in it:

options = {}
options['interface'] = ''
notebook(**options)

Edit /home/sage/bin/sagenb, find where it says:

"sage -notebook require_login=False"

and replace it with

"sage /home/sage/sagenboptions.sage require_login=False"

Go to the Desktop and double-click on "Sage Noteboook"

SAFETY WARNING: Don't do this if your machine is directly connected to the internet - a nasty cracker might come and steal/mess up/delete your files.


If anyone's interested, here's all the steps to get this system going:

  1. Download and install VirtualBox: http://www.virtualbox.org/

  2. Install the sage-vmware image in VirtualBox (the "extra tip" is unnecessary for this to work: http://groups.google.com/group/sage-support/msg/f6811b5729c3809e

  3. Set up a port forward between port 8000 on the host to port 8000 on the guest: http://www.virtualbox.org/manual/ch06.html#natforward

  4. Fix the network problems with this tip: http://blog.timc3.com/2010/05/04/vmware-ubuntu-ip-address-change/

  5. Perform the steps at the top of this answer

  6. Open a browser on the host system and point it to http://localhost:8000/. The default user is "admin", password "sage"

edit flag offensive delete link more

Comments

glad to hear you got it working -- thanks for sharing too!

niles gravatar imageniles ( 2010-12-04 12:26:12 -0500 )edit
0

answered 2010-12-01 16:37:03 -0500

niles gravatar image

There were some references in another recent VMWare Windows question -- are those helpful?

edit flag offensive delete link more

Comments

Not particularly - I've got the network running, I think the problem is related the webserver/SAGE configuration

sandyscott gravatar imagesandyscott ( 2010-12-02 00:34:34 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2010-12-01 11:34:47 -0500

Seen: 1,198 times

Last updated: Dec 04 '10