Keeping a stable connection between the notebook interface and the server

asked 2011-01-26 05:25:30 -0600

myildi gravatar image

updated 2011-01-26 05:28:26 -0600

Hello,

I have some difficulty to keep active the connection between the notebook interface in Firefox (the last stable version) and the Sage server. I execute Sage in the terminal, then start the notebook interface through notebook(). And quite quickly (as soon as I open an existing notebook) I loose the connection and get the following errors (see the last line - I have posted only one of them but this problem generates hundreds of them after the first one):

    sage: notebook()
The notebook files are stored in: sage_notebook.sagenb
**************************************************
*                                                *
* Open your web browser to http://localhost:8000 *
*                                                *
**************************************************
2011-01-26 17:53:29+0100 [-] Log opened.
2011-01-26 17:53:29+0100 [-] twistd 9.0.0 (/Applications/_Recherche/sage/local/bin/python 2.6.4) starting up.
2011-01-26 17:53:29+0100 [-] reactor class: twisted.internet.selectreactor.SelectReactor.
2011-01-26 17:53:29+0100 [-] twisted.web2.channel.http.HTTPFactory starting on 8000
2011-01-26 17:53:29+0100 [-] Starting factory <twisted.web2.channel.http.HTTPFactory instance at 0x10a118908>
2011-01-26 17:53:41+0100 [HTTPChannel,4,127.0.0.1] Request error: Connection to the other side was lost in a non-clean fashion.
edit retag flag offensive close merge delete

Comments

I'm sorry, but I haven't had problems like this (I also use Firefox) and I don't know what could be causing them . . . do you have the same difficulties if you use another web browser?

niles gravatar imageniles ( 2011-01-27 03:34:50 -0600 )edit

Hi Niles, I do get the same problem with Safari. I do not get it with Chrome but Chrome does not recognize java parts of the output even if the java plugin seems to be installed and activated... (here is what I see for Java in Chrome, in the plugins tab: Java - Version : 13.3.0 Java Plug-In 2 for NPAPI Browsers D├ęsactiver

myildi gravatar imagemyildi ( 2011-01-28 10:15:28 -0600 )edit

I have forgotten to tell that I can execute other Java applets in Chrome, but my 3D plots in Sage do not show. Also the top button bar in the notebook is replaced by black buttons.

myildi gravatar imagemyildi ( 2011-01-28 10:18:09 -0600 )edit

If you install the Firebug extension in Firefox and go to the Net or Console tabs, it will show you the communication happening back and forth. Taking a peek at that would probably provide some clues as to what is happening.

Jason Grout gravatar imageJason Grout ( 2011-02-08 18:33:23 -0600 )edit