Ask Your Question
1

Virtual machine appliance

asked 2013-02-20 10:35:14 -0600

nerak99 gravatar image

The sage appliance wiki suggests editing the sage user .bash_profile as follows

"and replace the line

./sage -notebook interface=\'\' port=8000 open_viewer=False require_login=False

with

./sage -notebook interface=\'\' port=8000 open_viewer=False require_login=True secure=True

however the 5.6 appliance does not have thses lines but merely alias=sage-hg

Where do I alter the notebook launch to make the appliance launch for other users.

edit retag flag offensive close merge delete

Comments

Sounds like the wiki needs an update - Volker, I hope you see this. That said, @nerak99, these options are in fact superseded since about Sage 5.4, and I'm not sure a satisfactory solution was found - see http://trac.sagemath.org/sage_trac/ticket/13318

kcrisman gravatar imagekcrisman ( 2013-02-20 14:45:25 -0600 )edit

Any info about how the launch now works would help me. I just need to intercept where sage is launched and chrome is also launched. Clearly not .bash_profile except via this alias thing?

nerak99 gravatar imagenerak99 ( 2013-02-20 22:57:43 -0600 )edit

FYI it appears to launch from .xinitrc. I expect I will be able to fix the thing to work as the wiki describes

nerak99 gravatar imagenerak99 ( 2013-02-20 23:20:46 -0600 )edit

Some of the wiki is outdated and needs to be changed, I know. Feel free to update it!

Volker Braun gravatar imageVolker Braun ( 2013-02-26 05:10:57 -0600 )edit

I made a stopgap change to http://wiki.sagemath.org/SageAppliance#Giving_Others_Access_to_the_Sage_Virtual_Machine but it would be great if someone who knew about this updated that more. Note however that you will want to keep the secure setting! I think there is an `automatic_login` that should probably be `False`...

kcrisman gravatar imagekcrisman ( 2013-02-26 05:19:21 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-02-25 21:06:54 -0600

nerak99 gravatar image

updated 2013-02-25 21:07:17 -0600

Essentially, the wiki is out of date because the launch is carried out in .xinitrc If you want a multiuser sage then comment out the xinit and shutdown -h now lines in .bash_profile and insert a sage launch line in .bash_profile. The program will now behave as expected.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-02-20 10:35:14 -0600

Seen: 129 times

Last updated: Feb 25 '13