Ask Your Question
0

Keyboard layout in Sage appliance

asked 2012-01-17 22:34:20 -0600

Green diod gravatar image

updated 2012-01-21 09:45:54 -0600

Hi all,

I'm currently testing Sagemath on a Windows 7 box via sage appliance (4.7.2). I wanted to try the interactive shell out but it is not usable as my host keyboard layout is fr and the guest fedora box for sage uses en.

A quick search pointed me to the system-config-keyboard command but too bad, it is not shipped with sage appliance 4.7.2. Any other hint ?

Final solution (see below): change layout via sudo nano /etc/sysconfig/keyboard

KEYTABLE="fr-latin1"
MODEL="pc105+inet"
LAYOUT="fr"
edit retag flag offensive close merge delete

4 answers

Sort by » oldest newest most voted
2

answered 2012-01-18 08:24:48 -0600

Volker Braun gravatar image

If you use your host OS browser to connect to the virtual machine then you'll be using your host keyboard settings. This is the preferred method.

To change the keyboard in the textmode console of the guest vm, drop to a shell and use the command

sudo loadkeys azerty

Note that system-config-keyboard is for configuring the keyboard in X, not for text mode.

edit flag offensive delete link more
1

answered 2013-09-24 10:53:02 -0600

Nicolas M Thiéry gravatar image

Here are some instructions we used last fall during a Sage workshop in a French speaking country; they might be outdated since then ...

Switch to the text console:

CTRL-ALT-F1

Log in:

login: sage
password: sage

Switch to user gui (might not be needed anymore)::

sudo su - gui

Edit the xinitrc file::

nano .xinitrc

Add the following line, just before the last line that starts google-chrome::

setxkbmap fr

Reboot:

reboot
edit flag offensive delete link more
0

answered 2012-08-15 22:35:33 -0600

doromi gravatar image

updated 2012-08-15 22:37:46 -0600

Hi,

I HAVE edited /etc/sysconfig/keyboard, and it nicely shows

KEYTABLE="de-latin1"
MODEL="pc105+inet"
LAYOUT="de"

I have restarted everything now (for several times... just to be sure), and on the shell the keyboard layout IS German, but in the Sage appliance it still is US... What else can I do / where else can I change something to get that German keytable working ?

edit flag offensive delete link more
0

answered 2012-01-19 06:39:54 -0600

Green diod gravatar image

Hi,

Thanks for theses infos.

Your hint works but is it possible to change the guest layout since booting up? I mean, I'm still stuck with the wrong layout until I can log in and use the history to load the good layout back.

edit flag offensive delete link more

Comments

1

You can make it permanent by editing /etc/sysconfig/keyboard

Volker Braun gravatar imageVolker Braun ( 2012-01-20 05:49:28 -0600 )edit

That's it, I updated my original question

Green diod gravatar imageGreen diod ( 2012-01-21 08:40:40 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-01-17 22:34:20 -0600

Seen: 5,342 times

Last updated: Sep 24 '13