Ask Your Question

Why does Sage not install with Vista?

asked 2011-08-15 11:39:18 +0100

Thaja gravatar image

updated 2015-01-13 21:23:44 +0100

FrédéricC gravatar image

I tried to obtain Sage 4.7 to my laptop which runs on Windows Vista. Following the suggestions given, I installed Oracle's VMVirtualbox ok and Sage 4.7. I installed the binary and did not attempt to use the source. After starting, the programme simply refuses to give me a Notebook and says incomprehensible(to me!) error messages about opening my web browser at localhost:0000 etc. I was able to go to the Sage directory and look at some of the files there but the instructions in the README.txt on the download web page simply does not correspond to reality. Any advice would be appreciated!

edit retag flag offensive close merge delete

5 Answers

Sort by » oldest newest most voted

answered 2011-11-01 17:38:03 +0100

advalencia gravatar image

After uninstalling, cleaning drivers and reinstalling the virtual machine, Adding a second network adapter with a host-only adapter solved the issue. I have tried this before, but I believe that I had some conflict with an old driver, I believe it was due to a previous installation of the Virtual machine, so I had to do a thorough clean up of drivers and old files (even after this the host-only adapter was required). Thank you Volker Dirk and Thaja for your help.

edit flag offensive delete link more

answered 2011-08-16 10:45:55 +0100

MaelstromYamato gravatar image

did you mean this link: "http://localhost:8000 "?

At which step are you stuck on in the ""?

edit flag offensive delete link more


Firstly step 4 didn't work as stated. When I did invoke/start Sage it claimed I hadn't set a password, but I was never asked for one!

Thaja gravatar imageThaja ( 2011-08-16 14:49:29 +0100 )edit

We changed the virtual machine to be a bit eaiser to use, and now you don't have to set a username/password any more. Just open your web browser and point it at http://localhost:8000 (NOT: 0000).

Volker Braun gravatar imageVolker Braun ( 2011-08-18 12:38:50 +0100 )edit

answered 2011-10-29 15:31:23 +0100

advalencia gravatar image

updated 2011-10-29 15:31:50 +0100

I tried the instructions, but when I try to open http://localhost:8000 it just stays there thinking. The last message in the virtual machine is Starting factory twisted.web2.... I tried both virtual box (1.147) and vmplayer ( with the sage-4.7.1.ova Thanks a lot for your help.

edit flag offensive delete link more


I'm a little confused about what you tried precisely. Did you open the browser on the virtual machine or on the Vista host machine?

Dirk Danckaert gravatar imageDirk Danckaert ( 2011-10-29 17:57:15 +0100 )edit

There is no browser or GUI in the virtual machine, so I assume it is on the host machine. You might be running some sort of firewall on the host that is preventing your web browser from opening the worksheet.

Volker Braun gravatar imageVolker Braun ( 2011-10-30 00:21:42 +0100 )edit

answered 2011-10-31 20:36:57 +0100

advalencia gravatar image

Let me correct this: It might be the network adapter in the VM , if I ctrl-c and then ifconfig, I only see the local loopback and no other adapters, I already reinstalled the VM and try to update the drivers, but no luck :( Any ideas? thanks to everyone.

edit flag offensive delete link more


ifconfig should show eth0 up and running. Are you sure you are running the latest version of VirtualBox (4.1.4 at this time)? The image has networking set up that it should work without changes. In Settings -> Network -> Adapter 1 you should have NAT and Intel PRO/1000.

Volker Braun gravatar imageVolker Braun ( 2011-11-01 12:19:00 +0100 )edit

answered 2011-10-31 18:31:05 +0100

advalencia gravatar image

Hello, thanks for the suggestions, I am running the browser in the host machine, I shut down Windows firewall but it didn't help, I'm getting a "The connection was reset" error message. The network connection to the vm seems to be OK as far as I can tell... any other ideas would be greatly appreciated.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2011-08-15 11:39:18 +0100

Seen: 748 times

Last updated: Nov 01 '11