Ask Your Question
0

How to get Sage 5.1 working under VMWare Player 4.0?

asked 2012-09-20 23:40:40 -0500

Jakob S. gravatar image

updated 2012-09-20 23:43:59 -0500

I want to use Sage 5.1 under VMWare Player 4.0.1 build-528992 . I successfully imported the virtual machine (sage-5.1.ova) by simply clicking open and ignoring any warnings (none of them seemed critical to me). However, when I now start the actual sage-5.1.vmx VM in the VMWare Player, it crashes (!) while booting the VM.

The last thing I can see is an error message after the login prompt:

sagevm login: [    5.655611] vboxguest: VirtualBox Guest PCI device not found.

Also there is another error message before:

[   4.219704] piix4_smbus 0000:00:07.3: Host SMBus controller not enabled!

I already changed the network settings to "Bridged" as suggested somewhere else.

I know that VirtualBox is recommended, but I do not have admin rights on my PC and have to cope with VMWare Player (which is installed).

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2012-09-22 00:04:02 -0500

Volker Braun gravatar image

Seems like VMware crashes on the VirtualBox guest extensions. Without being able to run the VM you can't uninstall the guest extensions. My suggestion would be to manually install Linux in VMware and then compile Sage from source in there.

edit flag offensive delete link more

Comments

Thanks for your answer - so I'll do it the hard way ;).

Jakob S. gravatar imageJakob S. ( 2012-09-23 19:57:27 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-09-20 23:40:40 -0500

Seen: 966 times

Last updated: Sep 22 '12