Ask Your Question
0

Sage on Windows network

asked 2011-09-27 06:42:22 -0500

mecus gravatar image

Hi I just successfully installed sage on windows 7 using virtual box. My question is, is it possible and how can I access sage from other computers on the network (sage runs on localhost:8000)

Please your answers will be highly appreciated.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2011-09-27 09:21:51 -0500

Dirk Danckaert gravatar image

Yes, it is. Right now we have a SAGE server running on a virtual Ubuntu 10.04LTS. It's accessible throughout our local network and even outside our school.

In my experience it's easier if you make SAGE's webserver listen on port 80. To do so start SAGE in a shell window, then issue the command

notebook(interface='',port=80)

I must confess there may be some security issues involved that, in our particular situation, don't matter much. I think, as long as the virtual machine is backed up and contains nothing but SAGE, the risks are minor. But if security is important for you, then consider this as a preliminary experiment.

Then, if you know the IP address xxx.xxx.xxx.xxx of your SAGE server, every computer on your local network can access the SAGE server by surfing to

http://xxx.xxx.xxx.xxx

I've read reports that Internet Explorer causes trouble sometimes, so I recommend Firefox. In our school students normally use IE8, with good results.

We further made things easy by defining a hostname in DNS, and publishing the server to the outside world through a Microsoft ISA server. All things considered, everything went very smoothly, and I was really impressed by how well the whole framework was thought out.

edit flag offensive delete link more
0

answered 2011-09-28 22:55:59 -0500

Volker Braun gravatar image

The VirtualBox image is set to only allow connections from the host that is running the virtual machine. Make sure to first change the root/sage account passwords and run the Sage server with security if you open it up to the network. Then, in VirtualBox, go to Settings->Network and change "Attached to: NAT" to Bridged Adapter.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-09-27 06:42:22 -0500

Seen: 422 times

Last updated: Sep 28 '11