Ask Your Question
0

Problem installing sagecell server

asked 2012-04-20 09:11:12 -0500

Shashank gravatar image

I was trying to install sagecell server and I tried it on the stable (4.8) as well as the unstable (5.0beta13). In both cases I get an error. In the case of 5.0beta13 it says

Patching Sage
adding 01-sage-embedded.patch to series file
applying 01-sage-embedded.patch
now at: 01-sage-embedded.patch
adding 02-sage-show.patch to series file
applying 02-sage-show.patch
patching file sage/plot/plot3d/base.pyx
Hunk #3 FAILED at 1137
1 out of 3 hunks FAILED -- saving rejects to file sage/plot/plot3d/base.pyx.rej
patch failed, unable to continue (try -v)
patch failed, rejects left in working dir
errors during apply, please fix and refresh 02-sage-show.patch
Error pushing patch 02-sage-show.patch.

Does anyone know to get rid of this error?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2012-04-20 16:38:19 -0500

Jason Grout gravatar image

My guess is that there is a conflict with a patch merged in beta13. I'm running it on beta12 and it seems fine. You could resolve the rejection (check the unmerged changes in sage/plot/plot3d/base.pyx.rej) and reinstall the sagecell spkg again. It will see that you have the patches already applied and it won't try to apply them again.

edit flag offensive delete link more

Comments

Is there a schedule for sage 5 release? And would the sage cell be more streamlined when that happens.

Shashank gravatar imageShashank ( 2012-04-20 18:55:57 -0500 )edit

Sage 5.0 is "real soon now", but there is not a definite schedule. It will streamline things a little, but you'll still have to install the new notebook at trac 11080. We'll fix these conflicts you ran into too, though, so at least that will not be a problem.

Jason Grout gravatar imageJason Grout ( 2012-04-23 03:43:20 -0500 )edit

Sage 5.0 is "real soon now", but there is not a definite schedule. It will streamline things a little, but you'll still have to install the new notebook at trac 11080. We'll fix these conflicts you ran into too, though, so at least that will not be a problem.

Jason Grout gravatar imageJason Grout ( 2012-04-23 03:43:20 -0500 )edit
1

Sage 5.0 is "real soon now", but there is not a definite schedule. It will streamline things a little, but you'll still have to install the new notebook at trac 11080. We'll fix these conflicts you ran into too, though, so at least that will not be a problem.

Jason Grout gravatar imageJason Grout ( 2012-04-23 03:43:21 -0500 )edit

sagecell installation works fine for me now. I upgraded my OS to Ubuntu 12.04 and tried sage-5beta14. I don't know what caused the error to go away but I was able to install sagecell server.

Shashank gravatar imageShashank ( 2012-04-30 16:47:46 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-04-20 09:11:12 -0500

Seen: 203 times

Last updated: Apr 20 '12