My notebook interface doesn't work

asked 2012-12-16 13:24:35 -0500

Joel B. gravatar image

updated 2012-12-16 14:49:51 -0500

I have a problem when I try to use sage with the notebook interface on my mac (a macbook pro under MacOS 10.7). When I launch a notebook interface, sage doesn't work. If I type 2+2 and click "evaluate", nothing happens. However, what is weird is that if I close the window and reopen it, then the answer is here "4".

Also, when I launch sage in a terminal instead, things work quite normally.
I have no idea of what is happening here. It used to work normally, until about two months ago. Since then I have tried everything I could think of, without success: quitting sage and relaunching it, killing all processes related to sage, restarting the computer, changing the browser (from safari to mozilla), reloading a new version of sage from the internet...

If anyone has any idea of what is happening and what I should try, thank you

edit retag flag offensive close merge delete

Comments

I think you want to either click the "evaluate" link or do "Shift+Enter".

kcrisman gravatar imagekcrisman ( 2012-12-16 14:13:49 -0500 )edit

@kcrisman. Actually that what I meant by "enter". I edit my post.

Joel B. gravatar imageJoel B. ( 2012-12-16 14:48:50 -0500 )edit

Huh, that *is* puzzling. Apparently the calculation is happening (you can even check this by looking at the text version of the worksheet in `.sage/sage_notebook.sagenb/home/admin/11/worksheet.html` (or whatever worksheet number you are in). Also, what happens if you access a remote Sage account, such as at sagenb.org? Knowing more about the exact version of Sage you have would be helpful, too.

kcrisman gravatar imagekcrisman ( 2012-12-17 06:15:15 -0500 )edit

Hi, does your problem perhaps look like the one at https://groups.google.com/forum/?fromgroups=#!topic/sage-devel/2FI5Fw9ywU8 ? It's conceivable that there is some weird permission problem... also, do you get any error messages in the Terminal when you try evaluating in the browser?

kcrisman gravatar imagekcrisman ( 2012-12-17 16:40:44 -0500 )edit

Thanks ksrisman for your comments. Things works well when I access a remote sage account. Also my version is 4.7.2. There is no error in the text version of the worksheet. And there doesn't seem to be permission error, as mentioned in the link you gave: if I type ls -l /home/knsam/.sage/sage_notebook.sagenb/home/admin/history.pickle I obtain -rwx------ 1 jbellaic jbellaic 641506 Aug 31 13:17 .sage/sage_notebook.sagenb/home/admin/history.pickle

Joel B. gravatar imageJoel B. ( 2012-12-20 08:06:12 -0500 )edit