Ask Your Question
3

syntax highlighting with sage-mode in emacs

asked 2012-06-18 08:57:38 -0500

Sean Lynch gravatar image

When I use sage with sage-mode in emacs, I don't get any syntax hightlighting. The sage promt is colored differently but anything I enter at the prompt is colored with the default face. I would assume that in the simplest case, if I was to write some python code it would be colored the same as if I was in a python-mode buffer.

Am i missing something here? I am using sage_mode-0.8.spkg

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
3

answered 2012-06-21 00:06:04 -0500

Ivan Andrus gravatar image

updated 2012-06-21 00:06:39 -0500

Currently syntax highlighting is only supported in Sage buffers, not in the interactive shell. I have created an issue on bitbucket where you can track the progress. I don't think it will be very difficult, but it's not my highest priority at the moment. Feel free to submit a pull request if you wish.

edit flag offensive delete link more

Comments

I have closed the issue and 0.8 will have the fix when it's released (hopefully soon).

Ivan Andrus gravatar imageIvan Andrus ( 2012-06-29 03:54:15 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-06-18 08:57:38 -0500

Seen: 374 times

Last updated: Jun 21 '12