Ask Your Question
1

Sage 9.2 on macOS 10.15.7 not working with conda method, either

asked 2020-11-11 19:15:34 -0600

murraye gravatar image

updated 2020-11-12 01:43:44 -0600

FrédéricC gravatar image

Along with others, I've reported that Sage 9.2 will not work on macOS because of a missing openssl. I tried the method using a conda environment described in https://groups.google.com/g/sage-deve... and at https://doc.sagemath.org/html/en/inst... but it doesn't work:

  • since I already have the full conda installed, I should not, and did not, install miniconda
  • instead, I just created and activated a sage environment using mamba with conda, as described.

That seemed to be OK, and using "conda activate sage" did open a sage conda environment. BUT:

  1. How do I start sage then? I tried just issuing the command "sage" on the Terminal command-line, in the sage conda environment. That gives a "Command not found" error.

    1. How do I go about using jupyter with sage using the conda method?
edit retag flag offensive close merge delete

Comments

What command did you run to create the sage conda environment?

slelievre gravatar imageslelievre ( 2020-11-14 07:20:04 -0600 )edit

The complete set of commands I used:

conda config --add channels conda-forge

conda install mamba -c conda-forge

mamba create -n sage sage -c conda-forge

conda init zsh

[restart Terminal]

conda activate sage

I now see command line prompt (in Terminal with zsh): (sage) [~] %

AHA! If I execute command "jupyter notebook" it opens the expected jupyter front end in Safari and allows me to use the Sage 9.2 kernel for evaluation.

And now executing in Terminal command "sage" does start sage at the command-line. (Not sure what I did wrong last time: when then I issued command "sage", that command was not found.

murraye gravatar imagemurraye ( 2020-11-15 10:53:00 -0600 )edit

Looks like your problem is solved then? Congratulations! Happy saging.

slelievre gravatar imageslelievre ( 2020-11-15 16:43:04 -0600 )edit

1 answer

Sort by » oldest newest most voted
1

answered 2020-11-12 15:30:44 -0600

isuruf gravatar image

You need to run sage in the same terminal that you ran conda activate sage

conda activate sage
sage
edit flag offensive delete link more

Comments

As I said, after issuing command "conda activate sage", I did -- in that same Terminal session -- issue command "sage", which gave the "command not found: sage" error!

murraye gravatar imagemurraye ( 2020-11-12 19:14:26 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-11-11 19:15:34 -0600

Seen: 85 times

Last updated: Nov 12