Problems installing Sage 8.3 on OSX

asked 2018-09-05 23:45:33 -0600

Gordon gravatar image

updated 2018-09-27 05:05:01 -0600

Iguananaut gravatar image

I am trying to install Sage 8.3 on OSX (latest version, 10.13.6)

I usually download the disk image and drag to Applications, so I attempted this with the file

sage-8.3-OSX_10.13.6-x86_64.dmg

and checked that the MD5 checksum matched the advertised MD5 sum on the download page.

On opening the disk image, a dialog saying "Verifying" opens up, and starts to verify, but then halts with an error message that I have not seen before:

"The following disk images couldn't be opened, (name of file), image data corrupted"

I downloaded again, and once again the MD5 checksum (called from a terminal window) was correct.

Then I ran Apple's "Disk Utility" and attempt to verify the image, which failed and produced a bunch of diagnostic data that I do not understand. (I have attached this diagnostic output in case it may be helpful)

Any assistance gratefully received.

Diagnostic output from "Disk Utility" starts here:

Checksumming Protective Master Boot Record (MBR : 0)…
Protective Master Boot Record (MBR :: verified   CRC32 $B149A7EF
Checksumming GPT Header (Primary GPT Header : 1)…
GPT Header (Primary GPT Header : 1): verified   CRC32 $D70C9635
Checksumming GPT Partition Data (Primary GPT Table : 2)…
GPT Partition Data (Primary GPT Tabl: verified   CRC32 $D7F0CD0F
Checksumming  (Apple_Free : 3)…
                (Apple_Free : 3): verified   CRC32 $00000000
Checksumming EFI System Partition (C12A7328-F81F-11D2-BA4B-00A0C93EC93B : 4)…
EFI System Partition (C12A7328-F81F-: verified   CRC32 $B54B659C
Checksumming disk image (Apple_APFS : 5)…
     disk image (Apple_APFS : 5): checksum failed with error 1000.
Operation failed with status 1000: image data corrupted
Operation failed…
edit retag flag offensive close merge delete

Comments

I don't know if anyone else has reported this problem. But if not then I suspect it is a problem with your machine.

Iguananaut gravatar imageIguananaut ( 2018-09-12 11:01:14 -0600 )edit

hi all, I have the same issue, I can't mount the sage-8.3-OSX_10.13.6-x86_64.dmg in Mac os 10.13.6 and please note that: MD5 (sage-8.3-OSX_10.13.6-x86_64.dmg) = 1aea38426661b68b0bcd0ee93b6afed7 whats the problem?

lisbeth gravatar imagelisbeth ( 2018-09-20 02:00:59 -0600 )edit

Beats me I don't build the OSX images. @slelievre?

Iguananaut gravatar imageIguananaut ( 2018-09-20 07:18:06 -0600 )edit

Same here... Image data corrupted. Quite annoying

Biel Cardona gravatar imageBiel Cardona ( 2018-09-27 04:07:14 -0600 )edit

Okay. It's probably a problem with the build then. I don't know how to fix that but I'll ask who can...

Iguananaut gravatar imageIguananaut ( 2018-09-27 05:04:43 -0600 )edit