Ask Your Question
1

Starting Sage from precompiled binary

asked 2018-05-26 02:52:50 -0500

IvanY gravatar image

Hello ! My operating system is Xubuntu 16.04.1 x86_64. I've downloaded sage-8.2-Ubuntu_16.04-x86_64.tar.bz2 precompiled binary archive and checked md5 sum. Beforehand I also checked sage prerequisites and installed them all, including openssl. However, after package untar and attempt to launch ./sage, the error message appears: It seems that you are attempting to run Sage from an unpacked source tarball, but you have not compiled it yet (or maybe the build has not finished). You should run make in the Sage root directory first. If you did not intend to build Sage from source, you should download a binary tarball instead. Read README.txt for more information.

Maybe someone have already encountered this problem? There might be some bug in sage installation check?

My intention is to install sagemath kernel to the existing jupyter installation. I tried to install kernelspec for the existing jupyter installation without running ./sage, and installation completes, but kernel can't start.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
2

answered 2018-05-30 17:29:15 -0500

IvanY gravatar image

Well, it appears that I overlooked the message "RecursionError: maximum recursion depth exceeded during compilation". So as it was already pointed (RecursionError: maximum recursion depth exceeded during compilation) the problem was related to the anaconda installation. Excluding conda from $PATH solved the problem.

edit flag offensive delete link more

Comments

You ought to be able to add back the conda path after first run of sage without trouble. At least, that's always worked for me on my macOS system.

j.c. gravatar imagej.c. ( 2018-05-30 22:40:04 -0500 )edit
1

answered 2018-05-26 16:09:30 -0500

Volker gravatar image

Works for me. Make sure you are in the correct directory; The archive contains a SageMath directory, which you have to change into (cd SageMath) before you run ./sage

The first time your run the sage script there will be a lot of messages about patching files to make them work in the new directory.

edit flag offensive delete link more

Comments

Well, I've run ./sage from the correct directory for sure. Otherwise, I wouldn't see any error messages related to "running Sage from an unpacked source tarball". It seems that Sage can't recognize correctly whether the source was precompiled or not. For some reason, it assumes that it wasn't compiled and asks me to run make and compile, although I did downloaded precompiled binary package.

IvanY gravatar imageIvanY ( 2018-05-26 18:18:14 -0500 )edit

Post terminal output for all steps...

Volker gravatar imageVolker ( 2018-05-27 03:28:43 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-05-26 02:47:15 -0500

Seen: 63 times

Last updated: May 30