Ask Your Question

RuntimeError when starting pari/library not found

asked 2016-06-09 14:58:27 +0200

fxrh gravatar image


I am using a binary distribution of sage 7.1 for debian jessie and "installed" it to /opt.

Now, when I want to use pari, I get a runtime error: sage: %gp --> Switching to PARI/GP interpreter <-- pari: sqrt(4) RuntimeError: unable to start pari

The full backtrace can be found here:

however, the following works: LD_LIBRARY_PATH=/opt/sage-7.1/local/lib sage It seems that sage is unable to find that library when starting pari.

Setting SAGE_ROOT does not help. Did I miss some configuration file to set the library path for sage?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2016-06-10 00:23:54 +0200

nbruin gravatar image

Binary distributions have a problem with "gp". See:

Your `LD_LIBRARY_PATH" workaround is reasonable, so if it works, that's great. The above ticket is resolved, so I expect new binary distributions shouldn't have this problem anymore. I don't know if 7.2 has already been produced with the fixed tools.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2016-06-09 14:58:27 +0200

Seen: 211 times

Last updated: Jun 10 '16