Ask Your Question
1

sage installation error

asked 2015-02-10 01:50:31 -0500

jsamadhan0 gravatar image

updated 2015-02-10 06:19:50 -0500

I get the following error while installing Sage :

checking for gcc option to accept ISO C99... unsupported
checking for sqrt in -lm... no
configure: This system has no maths library installed.
configure: error: Exiting, since a maths library was not found.
edit retag flag offensive close merge delete

Comments

Hello! Thanks for reporting this. We need a bit more detail to help. What is your operating system? (Ubuntu xx.yy? Mac OS X 10.x.y?) What version of Sage are you trying to install, where did you download it from and what command did you run?

slelievre gravatar imageslelievre ( 2015-02-10 05:51:18 -0500 )edit

I m using BOSS linux (5.1) -Debian based latest sage version binaries downloaded from sagemath make command gives that error

jsamadhan0 gravatar imagejsamadhan0 ( 2015-02-10 06:02:04 -0500 )edit

I have installed all prerequisites for sage but make command does not link maths library in gcc.

jsamadhan0 gravatar imagejsamadhan0 ( 2015-02-10 06:04:45 -0500 )edit

@jsamadhan0: you mean latest Sage source tarball, not binaries, right? If you download binaries, you don't have to run make, these should already be working. If you download source, then you compile it with 'make' to get a working Sage.

slelievre gravatar imageslelievre ( 2015-02-10 06:17:54 -0500 )edit

sorry for the mistake.I downloaded source tar.lmza and compiled it using make command

jsamadhan0 gravatar imagejsamadhan0 ( 2015-02-10 06:23:23 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-02-11 05:17:19 -0500

tmonteil gravatar image

Since your OS is Debian-based, before typing make, you can install the following packages (from most to less required) : build-essential binutils gcc make m4 perl tar openssl libssl-dev tk tk-dev texlive imagemagick dvipng ffmpeg

edit flag offensive delete link more

Comments

installed all prerequisites, but still the same error.

jsamadhan0 gravatar imagejsamadhan0 ( 2015-02-11 07:05:02 -0500 )edit
1

Could you try to type this before make:

export SAGE_INSTALL_GCC=yes
tmonteil gravatar imagetmonteil ( 2015-02-11 09:53:14 -0500 )edit

still the same problem

jsamadhan0 gravatar imagejsamadhan0 ( 2015-02-12 06:50:07 -0500 )edit

export SAGE_INSTALL_GCC=yes makes no difference, still the very same error

jsamadhan0 gravatar imagejsamadhan0 ( 2015-02-13 05:15:04 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-02-10 01:50:31 -0500

Seen: 318 times

Last updated: Feb 11 '15