!f2py not working

asked 2014-07-26 13:03:48 -0600

jjack gravatar image

updated 2014-07-26 15:23:56 -0600

Why is the command line F2PY tool not working with my sage installation?

The command !f2py on the sage shell returns

f2py*
-bash: f2py*: command not found

Do I have to be in the right folder for the tool to work?

I run sage in a virtual machine under Windows 7.

Sage 6.2 Documentation referring to f2py (the section referring to the command line tool is at the very bottom

edit retag flag offensive close merge delete

Comments

1

What do you mean by "does exactly nothing"? Does it just return you the Sage prompt? Does it output an error message then return the Sage prompt? Does it output some information about how to use f2py then return the Sage prompt? Does it not return the Sage prompt? If you include a copy-paste of input and output, and say what you were trying to do and what you expected to happen, it's easier to help. (Edit your question to add information.)

slelievre gravatar imageslelievre ( 2014-07-26 13:29:31 -0600 )edit

I provided further clarification to my question.

jjack gravatar imagejjack ( 2014-07-27 01:53:51 -0600 )edit

Is `f2py*` in your PATH?

kcrisman gravatar imagekcrisman ( 2014-08-01 20:25:29 -0600 )edit

!f2py at the sage: prompt should indeed return something like Usage: 1) To construct extension module sources: f2py [<options>] <fortran files=""> [[[only:]||[skip:]] \ etc. The question is whether the Sage 6.2. VM image has f2py installed. I don't know. In principle, one should be able to install it using the standard package management tool, from the shell prompt, for the corresponding Linux distribution (if it's Fedora then the tool is called yum).

Dima gravatar imageDima ( 2014-08-05 03:25:25 -0600 )edit