Ask Your Question
0

Version of software included in Sage

asked 2014-07-01 23:28:32 -0600

I am working in Sage 6.3.beta4 (built from the tarball) under OS X 10.9.3.

sage: version()
'Sage Version 6.3.beta4, Release Date: 2014-06-19'

To check what version of GAP, Maxima or R is included, the following works:

sage: gap.version()
'4.7.5'
sage: maxima.version()
'5.33.0'
sage: r.version()
((3, 0, 2), 'R version 3.0.2 (2013-09-25)')

but surprisingly this does not give the version of PARI, but raises an attribute error:

sage: pari.version()
AttributeError: 'sage.libs.pari.pari_instance.PariInstance' object has no attribute '__version'

It turns out that the following works:

sage: pari('version')
[2, 5, 5]

but it would be nice to access the version number for PARI in the same way as for other components.

For Singular, the naive trial as above outputs information giving the version number, followed by a Singular error.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-07-02 00:38:27 -0600

It's gp not pari:

sage: gp.version()
((2, 5, 5), 'GP/PARI CALCULATOR Version 2.5.5 (released)')
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-07-01 23:28:32 -0600

Seen: 43 times

Last updated: Jul 02 '14