Ask Your Question
0

jmol axes off-center

asked 2013-04-13 02:31:07 -0500

planarian gravatar image

Hi,

I'm new to Sage, and as I was trying to figure out plot3d and jmol, I noticed that when the axes are switched on, they appear off-center (if you put a point on the origin, it becomes quite obvious). I looked around to see if anyone else had noted this bug, and found this report from four years ago! I take it, then, that this problem won't be corrected in the foreseeable future, and I was wondering whether anyone has discovered a workaround.

Thanks!

edit retag flag offensive close merge delete

Comments

1

You may write your own code to add axes, see: http://ask.sagemath.org/question/1441/set-axes-in-3d-plot

ndomes gravatar imagendomes ( 2013-04-13 04:32:52 -0500 )edit

@ndomes: Thanks! My jury rig (see below) is probably good enough for now, but if it breaks down, I'll definitely use your suggestion.

planarian gravatar imageplanarian ( 2013-04-13 11:21:42 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-04-13 11:04:28 -0500

planarian gravatar image

updated 2013-04-13 11:35:11 -0500

I've discovered an odd fix, though I don't know how broadly applicable it is: before switching on the axes, use XY-Plane preset view under right-click->View. After the graph re-orients, toggle the axes (right-click->Style->Axes). At least in the handful of examples I've tried, it seems to correct the problem....

[EDIT: After further testing, I've decided this solution may not be worth the trouble. Sometimes the XY-Plane setting doesn't fix it, but YZ-Plane does. Clearly there are other variables at work....]

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-04-13 02:31:07 -0500

Seen: 378 times

Last updated: Apr 13 '13