Ask Your Question
0

.pdf text problem

asked 2010-11-08 08:31:48 -0500

dividenot gravatar image

updated 2011-04-28 08:53:43 -0500

Kelvin Li gravatar image

I have found some problems with Sages .pdf files. These issues occur many times within one document. To point one out, line 11, page 4 of reference.pdf, there is a line that goes off the page. That particular problem seems to be consistent throughout the document. Is there any fix for this?

Edit: Here is the offending example:

sage: sage.plot.plot.EMBEDDED_MODE = True 
sage: trace(’print factor(10)’) 
... 
NotImplementedError: the trace command is not implemented in the Sage notebook; you must use the

at which point it goes off the page.

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2011-01-03 14:45:50 -0500

kcrisman gravatar image

It appears that the reference manual (and other pdfs) are doing two things wrong.

  • They are doing what you describe.
  • They somehow logically process in such a way that when the text gets to the end of the standard page, the words beyond that (in this case, "must use the") are in a separate selection area when you select text.

Naturally in the html version all is well:

sage: sage.plot.plot.EMBEDDED_MODE = True
sage: trace('print factor(10)')
...
NotImplementedError: the trace command is not implemented in the Sage notebook; you must use the command line.

I'm not sure there is any way to ask Sphinx to format this correctly. This isn't exactly an answer, but hopefully will help someone else...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2010-11-08 08:31:48 -0500

Seen: 142 times

Last updated: Jan 03 '11