Ask Your Question
0

Jmol in Notebook

asked 2011-08-19 05:47:02 -0500

Anne Schilling gravatar image

updated 2011-08-19 06:06:25 -0500

kcrisman gravatar image

Hi!

I am trying to use the following commands in the notebook:

sage: x, y, z = var('x, y, z')
sage: plot3d(x^2 + y^2, (x,-2,2), (y,-2,2))

but Jmol terminates and just returns a black picture. These commands work fine in the command line. I tried this both on my laptop and on the notebook server at sage.lacim.uqam.ca. Is there some configuration necessary to display jmol pictures in the notebook?

Thanks,

Anne

edit retag flag offensive close merge delete

Comments

This is almost certainly to do with your specific configuration. We have had these kinds of issues on a recurring basis. I would suggest searching sage-support (though it's hard to do sometimes) for this. Sometimes it's a Linux thing, sometimes you need to update your Java, and sometimes it's a bug. What version do you have? We did fix some of these things in patches that should be in 4.7.

kcrisman gravatar imagekcrisman ( 2011-08-19 06:06:05 -0500 )edit

If you are using Mac OS X + Chrome there is a good thread on sage-support, although that problem was fixed (at least in 4.7.1). You may need to enable your browser to load java applets. Try going to http://jmol.sourceforge.net/demo/alphahelix/ and see if the jmol applet loads.

benjaminfjones gravatar imagebenjaminfjones ( 2011-08-19 07:31:34 -0500 )edit

Thank you for your answers. I am running sage-4.7.1 under Mac OS. The jmol applet loads fine for me when I go to http://jmol.sourceforge.net/demo/alphahelix/ . I am not sure which operating system http://sage.lacim.uqam.ca uses, but the sage version there is sage-4.7. You can get a free account and see whether the problem also occurs for you there.

Anne Schilling gravatar imageAnne Schilling ( 2011-08-19 12:15:41 -0500 )edit

Thank you for your answers. I am running sage-4.7.1 under Mac OS. The jmol applet loads fine for me when I go to http://jmol.sourceforge.net/demo/alphahelix/ . I am not sure which operating system http://sage.lacim.uqam.ca uses, but the sage version there is sage-4.7. You can get a free account and see whether the problem also occurs for you there.

Anne Schilling gravatar imageAnne Schilling ( 2011-08-19 12:15:42 -0500 )edit

PS: I am using Firefox.

Anne Schilling gravatar imageAnne Schilling ( 2011-08-19 12:23:53 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2011-08-19 18:14:27 -0500

benjaminfjones gravatar image

updated 2011-08-20 14:06:06 -0500

I just tried pasting your code into the server http://sage.lacim.uqam.ca where I created a new account. Everything worked like it should for me, jMol starts (slowly, but that's ok), and I get a 3d interactive plot.

I've had problems with jMol before that were miraculously solved by clearing my browser cache and history data. I'd recommend:

  1. update firefox to the most recent version
  2. clear all browsing data (cache, cookies, etc..)
  3. try again

See if that solves the problem. This reminds me about a joke involving an engineer, a physicist, and a computer scientist in a broken down car...

-- Update --

If it seems to work in Safari, try putting this in your .bashrc (or .bash_profile) file:

export SAGE_BROWSER='open -a Safari'
edit flag offensive delete link more

Comments

Well, I updated to Firefox 6.0, cleared all browsing data, but it still does not work for me. I still get a black picture and a little note saying "jmol script terminated". It does work with Safari, however. But then I am having trouble getting sage to use a non-default browser. I put export SAGE_BROWSER="/Applications/Safari.app/Contents/MacOS/Safari" in my .bashrc file, but then Safari complains that it cannot find certain files. Did you use firefox when you tried the lacim server?

Anne Schilling gravatar imageAnne Schilling ( 2011-08-20 08:31:26 -0500 )edit

My problem seems to be the same as in http://groups.google.com/group/sage-support/browse_frm/thread/f726900d8281508e/0fb1328060b9b83c?tvc=1&q=Jmol#0fb1328060b9b83c . There is no answer there. Was this issue ever resolved?

Anne Schilling gravatar imageAnne Schilling ( 2011-08-20 14:40:10 -0500 )edit

Thank you, your export statement for Safari works! It would still be good to understand the Firefox problem at some point since from the threads in sage-support it seems that others have had the same problem.

Anne Schilling gravatar imageAnne Schilling ( 2011-08-20 19:32:08 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-08-19 05:47:02 -0500

Seen: 963 times

Last updated: Aug 20 '11