Ask Your Question

Revision history [back]

Trouble logging into notebook

Hi, sorry for such a basic question, but it's been frustrating me to no end and I'm not sure what's going on. I am running the Sage 5.7 application on OS X 10.6.8 with Safari. I installed the package, ran Sage Server, and a notebook opened up in Safari with me automatically logged in.

Whenever I close the notebook window and try to open a new one, I get a login screen, and since I never set a password, I can't log in. I've tried all combinations involving restarting the Sage server and Safari, but once I start seeing the login screen, the only way I've found to get back in is to reboot the machine.

I've opened a Sage terminal and tried to run notebook with automatic_login=True. The login screen still pops up. I've tried it with reset=True and typed in a new admin password. The login screen tells me the new password is wrong. I haven't been able to find any documentation that addresses my issue as everything seems to assume I made an account when I first ran notebook, which I didn't, and I'm at a complete loss as to what to do. Any help would be greatly appreciated! Thanks!