Ask Your Question
0

Compiling SAGE 5.5 -- Matplot Lib Fails to find Numpy

asked 2013-01-07 05:27:37 -0500

DrWhom gravatar image

updated 2015-01-14 07:47:27 -0500

FrédéricC gravatar image

I'm currently compiling SAGE 5.5 and running in to the following errors (from the install.log):

68513 ==========================================================================      ==
68514 BUILDING MATPLOTLIB
68515             matplotlib: 1.1.0
68516                 python: 2.7.3 (default, Jan  7 2013, 11:22:35)  [GCC 4.4.6
68517                         20120305 (Red Hat 4.4.6-4)]
68518               platform: linux2
68519 
68520 REQUIRED DEPENDENCIES
68521                  numpy: no
68522                         * You must install numpy 1.1 or later to build
68523                         * matplotlib.
68524 Error building matplotlib package.

However, if I check the installation of numpy in install.log, I see the following:

63222 Successfully installed numpy-1.5.1.p1

Why is matplotlib not finding numpy? Is there a way of forcing the path? This seems like something that should "Just Work".

My build process:

  1. Untar sage-5.5
  2. cd sage-5.5
  3. make

ADDENDUM:

I've included a bit more debugging information, some things removed for privacy sake. CPU: Intel(R) Xeon(R) CPU W3530 @ 2.80GHz Memory: 12GB Operating System: RHEL 6 Kernel: 2.6.32-279.19.1.el6.x86_64

Compiler:

Using built-in specs.
Target: x86_64-redhat-linux
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man 
--infodir=/usr/share/info --with-bugurl=http://bugzilla.redhat.com/bugzilla 
--enable-bootstrap --enable-shared --enable-threads=posix 
--enable-checking=release --with-system-zlib --enable-__cxa_atexit 
--disable-libunwind-exceptions --enable-gnu-unique-object 
--enable-languages=c,c++,objc,obj-c++,java,fortran,ada --enable-java-awt=gtk 
--disable-dssi --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-1.5.0.0/jre 
--enable-libgcj-multifile --enable-java-maintainer-mode 
--with-ecj-jar=/usr/share/java/eclipse-ecj.jar --disable-libjava-multilib 
--with-ppl --with-cloog --with-tune=generic --with-arch_32=i686 
--build=x86_64-redhat-linux
Thread model: posix
gcc version 4.4.6 20120305 (Red Hat 4.4.6-4) (GCC)

Environmental Variables:

MALLOC_CHECK_=1
SHELL=/bin/bash
TERM=screen
HISTSIZE=1000
QTDIR=/usr/lib64/qt-3.3
QTINC=/usr/lib64/qt-3.3/include
SSH_TTY=/dev/pts/0
     LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.tbz=01;31:*.tbz2=01;31:*.bz=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4 ...
(more)
edit retag flag offensive close merge delete

Comments

Absolutely this should "just work". Is there any other information about your machine and OS you can provide other than that already in your original message which might help someone track this down? (processor, unusual env vars set, etc.)

kcrisman gravatar imagekcrisman ( 2013-01-07 05:36:13 -0500 )edit

kcrisman, I've updated the original post (for organization's sake) with extra information including OS, kernel version, and environmental variables, minus a few that are not of interest to this case.

DrWhom gravatar imageDrWhom ( 2013-01-07 05:47:56 -0500 )edit

1 answer

Sort by » oldest newest most voted
1

answered 2013-01-07 08:10:36 -0500

DrWhom gravatar image

After some more fiddling, I've found the solution to my problem.

Sage's built-in version of Python will look, by default, without any prompting from environmental variables (as you can see from the list of environmental variables dumped above) took look in the ~/.local directory. If a .local exists for some reason and includes various python packages, SAGE will attempt to load them during the build process instead of the packages it has compiled as part of its build. I'm unsure if this is the intended behavior of the build process.

As a side note I have no recollection of ever creating or putting anything in the .local directory. Its removal had subsequently no visible effect on my local python installation.

edit flag offensive delete link more

Comments

I'll post a comment to that effect on sage-devel - it's possible this is a feature, and it's possible this is a bug.

kcrisman gravatar imagekcrisman ( 2013-01-08 03:35:10 -0500 )edit

Excellent! Thanks a lot!

DrWhom gravatar imageDrWhom ( 2013-01-11 02:42:35 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-01-07 05:27:37 -0500

Seen: 394 times

Last updated: Jan 07 '13