Interactive 3D plots

asked 2012-11-25 10:49:23 -0600

dw1 gravatar image

updated 2012-11-25 12:23:38 -0600

Hello - I have recently installed Sage 5.4.1, on a Ubuntu 12.04 machine, from both tarred binaries

sage-5.4-linux-32bit-ubuntu_12.04.1_lts-i686-Linux.tar.lxma

and again from the packages at aims/sagemath.

Also I have experimented with multiple (both Oracle and openjdk) versions of java, and also with both chromium and firefox browsers.

In all combinations yet tried, I get exactly the same result. Which is: most sage functionality that I try seem to work fine (and I like it!) but I cannot interactively view any 3D plots, because of the "/cells/14/cells/14" path problem, which, frustratingly, my google searches indicate seems to have afflicted various people over a period of years. [Later clarification added: I am new to sage and first began working only in notebook mode using my browser (after always starting sage using /usr/bin/sage -notebook). I have subsequently found that I can always enter the same 3D plotting commands directly into a sage session within the linux command console after starting sage with merely /usr/bin/sage without the -notebook switch. -That way I am able to interact with the 3D plot, since jmol starts up and displays it OK. In other words, my problem with accessing the 3D plots seems to be a sage notebook problem only. (But it is not simply an applet problem: the jmol applet seems to work fine, with interaction, when I browse to non-sage-related 3D jmol graphics using the same browser without use of sage.)]

Can anyone suggest what might be next for me to try - with the aim of getting a sage version in which I can view 3D plots interactively? Thanks

PS A bit more detail on what I, above, called "/cells/14/cells/14" problem. You can find 500 hits on this by googling "cells/14/cells/14" "sage"

The problem seems to be that when I request in a notebook to interact with a 3D plot, my installed sage writes some zipped jmol data, to a directory it creates, accompanied by a script that incorrectly doubles up part of the pathname that it has just created. The consequence seems to be that sage (or perhaps the jmol applet) cannot then find its own files, since it is referring to them with a wrong pathname.

E.g.

complete contents of the sage-created 2-line script file, named sage0-size500.jmol, are:

set defaultdirectory "/home/_sage_/38/cells/14/cells/14/sage0-size500-78692106.jmol.zip" script SCRIPT

It is clear (from browsing my disk) that the immediate reason for the failure of the applet to display the plot is that the repetition of "/cells/14" in this path is incorrect.

Two supplementary questions relating to possible work-arounds, if it turns out that I cannot easily fix this on my machine:

  1. Is there a way to export its 3d plots out of sage and then view them directly with jmol? [Update: My bold square-bracketed insertion above provides a sort of partial answer here.]

  2. Are there ubuntu 12 ...

(more)
edit retag flag offensive close merge delete

Comments

If you could update the Google search, that would be helpful; I didn't get many useful results with the one you suggest. That said, your example makes the problem very clear, thanks for the specificity!

kcrisman gravatar imagekcrisman ( 2012-11-26 03:33:53 -0600 )edit