Ask Your Question
1

File size limitations for uploading into DATA folder

asked 2012-10-21 04:43:31 -0500

azerbajdzan gravatar image

I wanted to upload a file into DATA folder in Sage, but got the following error: Bad Request Maximum length of 10485760 bytes exceeded.

I guess there is a limitation 10MB on the size of a file. How can I change this limitation?

edit retag flag offensive close merge delete

Comments

I have used numpy's genfromtxt command to import data in to sage and I have imported a file larger than 5GB. Is there a reason why you are trying to put it in the data folder rather than import using numpy?

Shashank gravatar imageShashank ( 2012-10-23 10:32:29 -0500 )edit

I use Sage in Windows with Oracle VM VirtualBox. So I guess I can not simply access files in my local disk. I have first to upload files to DATA directory and then access file like this: f=open(DATA+'f.txt'); But if f.txt is bigger than 10MB I cannot upload it because I get the above error. If file is smaller than 10MB it works without any trouble.

azerbajdzan gravatar imageazerbajdzan ( 2012-10-23 12:36:20 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2012-10-27 07:01:53 -0500

azerbajdzan gravatar image

Is there anybody who runs Sage Notebook in Windows using Oracle VM VirtualBox?

edit flag offensive delete link more
0

answered 2012-10-24 06:31:22 -0500

Jason Grout gravatar image

The limit is almost certainly a limitation of the webserver serving the notebook. If you are using twisted (i.e., the server Sage comes with), it may be a manifestation of a limitation of twisted: http://twistedmatrix.com/trac/ticket/... may be relevant. In any case, using something like nginx/uwsgi or apache to serv the Sage notebook may make it easier to adjust this limit.

edit flag offensive delete link more

Comments

I have two options to upload file to DATA folder. 1. "Browse your computer to select a file to upload:" 2. "Or enter the URL of a file on the web:". The method 2, i.e. uploading from the web works without limitation but if I want to upload a local file using method 1 then there is that limit 10MB. So it must be an error in Sage, or if not then it must be possible to change the limit, but I do not know how.

azerbajdzan gravatar imageazerbajdzan ( 2012-10-24 08:31:08 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-10-21 04:43:31 -0500

Seen: 189 times

Last updated: Oct 27 '12