SSR Security Access Issues

asked 2012-05-31 11:27:21 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

Greetings! I have set up the Ubuntu64bit 10.04.3 version of Sage Math on a server at RackSpace Cloud I am renting to use as a remote Sage Math server. as long as I set secure=True and also run the "screen" tool for Linux, the sage notebook runs fine. My intention is to use Sage Math as a resource for teaching math in the virtual world of Second Life. Now I can access the published worksheets from www.sagenb.org/pub from within Second Life without any trouble and display them in-world. This is important for my educational purposes on Second Life where I have a virtual school. In the case of my server at Rackspace, I can easily access published worksheets with a regular browser but I cannot do so from within Second Life. I get the error message that SSL handshake failed. I tried reinstalling Sage Math without using SSL but the notebook refuses to function if I do that, and eventually the installation becomes corrupt if I keep trying. I was forced to rebuild the server from scratch and download the Sage Math program to get things working again. Now, obviously it is possible to access the published worksheets since I had no trouble with this on www.sagenb.org/pub, so i would like to know how to accomplish this on my server. security is not a big deal as no important data is intended to be stored on it, it is just to facilitate interaction. I wouldnt mind running the notebook server unsecured if only it would let me. So far I have not figured out any solution to the problem and would really appreciate some help. Thank You, Math Bear

edit retag flag offensive close merge delete

Comments

+1 just 'cause the idea of using Sage in a virtual world is cool.

DSM gravatar imageDSM ( 2012-06-01 05:54:55 -0500 )edit

My guess would be that the web browser in Second Life doesn't support self-signed SSL certificates. Getting an officially signed certificate costs real money. It could also be that it doesn't support non-standard port numbers. Non-privileged processes can't bind to port 80. Its probably easiest to set up a firewall rule that redirects port 80 to 8000 or wherever you are running the notebook process.

Volker Braun gravatar imageVolker Braun ( 2012-06-03 06:16:15 -0500 )edit