Ask Your Question

compilation problem: 4.6 on Fedora 11

asked 2010-11-05 10:04:44 +0200

finotti gravatar image

updated 2011-04-28 17:16:04 +0200

Kelvin Li gravatar image


I am trying to install from source version 4.6. The computer is a Dell server running Fedora 11.

boole[~]$ uname -a
Linux #1 SMP Thu Feb 11 07:06:34 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux

Here is the end of install.log:

stark.o ../src/modules/stark.c
gcc  -c -O3 -Wall -fno-strict-aliasing -fomit-frame-pointer  -O3 -g   -I. -I../src/headers -fPIC -o subfield.o ../src/modules/subfield.c
gcc  -c -O3 -Wall -fno-strict-aliasing -fomit-frame-pointer  -O3 -g   -I. -I../src/headers -fPIC -o thue.o ../src/modules/thue.c
gcc: Internal error: Killed (program cc1)
Please submit a full bug report.
See <> for instructions.
make[3]: *** [base3.o] Error 1
make[3]: Leaving directory `/work/local/sage-4.6/spkg/build/pari-2.4.3.svn-12577.p9/src/Olinux-x86_64'
make[2]: *** [gp] Error 2
make[2]: Leaving directory `/work/local/sage-4.6/spkg/build/pari-2.4.3.svn-12577.p9/src'
Error building GP

real    111m27.732s
user    112m57.112s
sys     1m18.139s
sage: An error occurred while installing pari-2.4.3.svn-12577.p9
Please email sage-devel
explaining the problem and send the relevant part of
of /scratch/local/sage-4.6/install.log.  Describe your computer, operating system, etc.
If you want to try to fix the problem yourself, *don't* just cd to
/scratch/local/sage-4.6/spkg/build/pari-2.4.3.svn-12577.p9 and type 'make check' or whatever is appropriate.
Instead, the following commands setup all environment variables
correctly and load a subshell for you to debug the error:
(cd '/scratch/local/sage-4.6/spkg/build/pari-2.4.3.svn-12577.p9' && '/scratch/local/sage-4.6/sage' -sh)
When you are done debugging, you can type "exit" to leave the
make[1]: *** [installed/pari-2.4.3.svn-12577.p9] Error 1
make[1]: Leaving directory `/work/local/sage-4.6/spkg'

real    143m41.614s
user    143m27.691s
sys     9m26.463s
Error building Sage.

Any ideas?



edit retag flag offensive close merge delete


Fedora is a chronically unstable distro. =) Ubuntu 10.x and 9.x compile great!

ccanonc gravatar imageccanonc ( 2010-11-05 15:01:40 +0200 )edit

the "quote" or "format code" buttons in the editor will do the trick of inserting the preformatted text.

Evgeny gravatar imageEvgeny ( 2010-11-05 16:28:21 +0200 )edit

Nice coloring :-)

ccanonc gravatar imageccanonc ( 2010-11-05 17:34:03 +0200 )edit

Thanks Evgeny. I hadn't noticed the code buttom...

finotti gravatar imagefinotti ( 2010-11-05 17:50:53 +0200 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2010-11-05 15:23:38 +0200

Mike Witt gravatar image

For whatever it's worth, on my Fedora 11 system I had to do:

export SAGE_DEBUG=yes

Before doing the make. This solved a "similar" problem, but I'm not sure if it's really the same problem or not. Might be worth a try. There were other work-arounds posted on

but the DEBUG thing above worked best in my situation.


edit flag offensive delete link more


Thanks! This worked perfectly.

finotti gravatar imagefinotti ( 2010-11-05 17:48:04 +0200 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2010-11-05 10:04:44 +0200

Seen: 400 times

Last updated: Nov 05 '10