Ask Your Question
2

Unable to install glucose SAT solver with Sage

asked 2022-06-17 18:18:04 +0200

hhhults gravatar image

updated 2022-06-30 21:03:09 +0200

FrédéricC gravatar image

Hi all, I have sage 9.5 installed through anaconda. Following the instructions found on Sebastien Labbe's blog (can't post a link due to insufficient karma), I tried "sage -i glucose" to install glucose to no avail. The error message I got was:

"make: * No rule to make target 'all-toolchain'. Stop."

I googled it and found other people with this problem, they were told to install sage a different way. So I installed version 9.6 via "brew install --cask sage" and then when I try "sage -i glucose" again I get:

"Sorry, this binary distribution does not support installing sage packages. If glucose is available from pypi you may install it by running %pip install glucose from the sage prompt."

pip install glucose certainly doesn't work because it isn't a python package.

I looked up this error and found that perhaps I need to install from source in order to get the functionality for installing optional packages? So I downloaded the .tar.gz from the 3-manifolds GitHub repo and attempted to follow the instructions in the SETUP/readme files from there. Those seem to be outdated, as the instructions in them assume a directory structure that is not present in the form that I downloaded it. So, at this point I'm pretty stumped. I have combed myriad forum posts and tried lots of solutions but none of them worked. Does anyone have any tips/pointers? Many thanks.

edit retag flag offensive close merge delete

Comments

I updated the blog post Using Glucose SAT solver to find a tiling of a rectangle by polyominoes warning that sage -i glucose no longer works and added a link to this current question. Thank you.

Sébastien gravatar imageSébastien ( 2022-06-20 09:59:45 +0200 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2022-06-17 20:15:24 +0200

slelievre gravatar image

updated 2022-06-17 20:33:38 +0200

Follow the instructions for building from source at

replacing the instruction

./configure

by

./configure --enable-glucose

For the source tarball, use the one found at either

edit flag offensive delete link more

Comments

This worked! Thank you so much.

hhhults gravatar imagehhhults ( 2022-06-18 00:13:49 +0200 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2022-06-17 18:18:04 +0200

Seen: 60 times

Last updated: Jun 17