Ask Your Question
1

SAGE - python3 problem import multiprocessing_logging

asked 2021-06-02 11:35:46 +0100

Miroslaw gravatar image

updated 2021-06-02 11:38:15 +0100

Dear Collegues,

I need help , I'm trying two days and got headheach:(

system: UBUNTU 20.04
installed SAGE - 64 bit
Python version 3.8

problem is with import modules:

ubuntu@ubuntu2010:~/Desktop/APPS/bdd-predicate$ sage -python3 ecdsa_cli.py
Traceback (most recent call last):
  File "/home/ubuntu/Desktop/APPS/bdd-predicate/ecdsa_cli.py", line 14, in <module>
    from multiprocessing_logging import install_mp_handler
ModuleNotFoundError: No module named 'multiprocessing_logging'

but i have installed:

Python 3.8.6 (default, May 27 2021, 13:28:02) 
[GCC 10.2.0] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import multiprocessing_logging
>>>

when I want to once again install multiprocessing_logging:

ubuntu@ubuntu2010:~/Desktop/APPS/bdd-predicate$ pip3 install multiprocessing_logging
Requirement already satisfied: multiprocessing_logging in /usr/local/lib/python3.8/dist-packages/multiprocessing_logging-0.3.1-py3.8.egg (0.3.1)
ubuntu@ubuntu2010:~/Desktop/APPS/bdd-predicate$

how to solve this problem? please help,

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2021-06-02 11:39:51 +0100

FrédéricC gravatar image

updated 2021-06-02 14:08:43 +0100

slelievre gravatar image

Most probably your python3 is not Sage's python3.

Install multiprocessing_logging in Sage's own python3.

See for example the answer to

edit flag offensive delete link more

Comments

FrédéricC perfect works.

Miroslaw gravatar imageMiroslaw ( 2021-06-02 12:24:46 +0100 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2021-06-02 11:35:46 +0100

Seen: 83 times

Last updated: Jun 02