Ask Your Question
1

Error installing Jupyterlab in macOS

asked 2020-12-04 18:23:09 +0200

Juanjo gravatar image

updated 2021-03-25 13:12:03 +0200

FrédéricC gravatar image

On macOS, with SageMath 9.2 installed via Conda, I tried to install Jupyterlab as follows:

(sage) $ sage -i jupyterlab_widgets

However, I get the following error message:

make: *** No rule to make target 'all-toolchain'.  Stop.

The same error appears if I only try

(sage) $ sage -i jupyterlab

How can I avoid this error and complete the install?

Additional information. I am using a MacBook Pro with macOS 10.13.6, and SageMath 9.2 was installed using conda as follows:

$ conda config --add channels conda-forge
$ conda config --set channel_priority strict
$ conda create -n sage sage python=3.8

I can launch SageMath in the Jupyter notebook with no problems using the commands:

$ conda activate sage
(sage) $ sage -n jupyter

Many thanks.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2020-12-05 00:40:12 +0200

Juanjo gravatar image

I answer myself. I found that I could directly use pip. The command

sage -pip install jupyterlab_widgets

did the trick.

edit flag offensive delete link more

Comments

Congratulations! You can accept your own answer to mark your question as solved.

slelievre gravatar imageslelievre ( 2020-12-05 18:33:53 +0200 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-12-04 18:23:09 +0200

Seen: 117 times

Last updated: Dec 05 '20