jmol in sage notebook on mint 19

asked 2019-03-26 08:51:02 -0500

msage gravatar image

updated 2019-03-26 08:53:15 -0500

Hello, I used self compiled sage the last years, now sage is packed with ubuntu/mint so I use the debian package.

I have SageMath version 8.1, Release Date: 2017-12-07 on Mint 19.2.

I need 3d vektor plots in sagenotebook.

But I get following error in notebook:

XXXXXXXXXXXXXX
Interactive 3D plots using the default viewer do not work in SageNB, because JSmol cannot currently be packaged for Debian. See the README.source of the jmol package for more details on this situation. You have the following alternative options:

View an interactive WebGL-based plot by giving the option viewer='threejs'. This should work out-of-the box on Firefox, but may require you to adjust some settings in Chromium - see chrome://flags for options and chrome://gpu for status. In both cases, the functionality also depends on your graphics hardware and drivers, but support should exist in most cases. View a less sophisticated interactive plot that does not require WebGL, by giving the option viewer='canvas3d'. View a non-interactive plot by giving the option viewer='tachyon'. Use the default viewer (Jmol) from the SageMath command-line interface, instead of the notebook.

XXXXXXXXXXXXXX

Nothing of the suggestions works. So I installed Java 8 and then I can run jmol applet from sage commandline. But that's not what I want.

I also tried to compile Sage 8.7 myself. Same problem. I don't need JSMOL viewer in notebool. JMOL Java applet would be best. In older Sage Version 7.5.1 on an ubuntu 12.04 it runs fine. what can I do that it also runs in on my mint machine?

Can I replace jmol in the sourcedirectory and compile? How?

How can I change viewer between JSMOL and JMOL? Any help is appreciated. Any ideas? Thank you

edit retag flag offensive close merge delete