Ask Your Question

Documentation erratum

asked 2019-01-03 13:08:38 +0200

sagenotdead gravatar image

In the official documentation:

the section related to the command "full_simplify()" should be renamed as "simplify_full()".

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted

answered 2019-01-03 13:36:15 +0200

vdelecroix gravatar image

Why is that? Both functions work identically

sage: E = (x^2 + 2*x + 1) / (x + 1)
sage: E
(x^2 + 2*x + 1)/(x + 1)
sage: E.full_simplify()
x + 1
sage: E.simplify_full()
x + 1

Actually one is an alias of the other

sage: E.full_simplify == E.simplify_full

I would rather update the documentation to mention that both names are valid.

edit flag offensive delete link more


Ok it is. It seems very strange to have such alias (⊙_⊙')

sagenotdead gravatar imagesagenotdead ( 2019-01-03 14:13:51 +0200 )edit

simplify_full exists so that it appears under tab completion on E.simplify. full_simplify exists maybe because sometimes people use this name (in maple?, in mathematica? for instance)

Sébastien gravatar imageSébastien ( 2019-01-03 17:31:45 +0200 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2019-01-03 13:08:38 +0200

Seen: 438 times

Last updated: Jan 03 '19