'launched jmol viewer for Graphics3d Object' fails

asked 2017-10-25 16:27:25 -0600

c05772 gravatar image

updated 2017-11-22 06:03:19 -0600

FrédéricC gravatar image

Testing Sagemath for windows 8.0 with jmol, I get the message at the console but nothing happens. However the jmol viewer (launched with jmol.bat) found in C:\Program Files\SageMath 8.0\runtime\opt\sagemath-8.0\local\share\jmol is working correctly.

> sage: G=sphere((0,0,0),1) 
> sage: show(G,figsize=(5,5),title="Sample Figure",aspect_ratio=1); 
> Launched jmol viewer for Graphics3d Object  
> sage:

It looks like a path problem but I don't see how to modify it.

edit retag flag offensive close merge delete

Comments

You are probably right. A workaround would be to use the Tachyon viewer.

kcrisman gravatar imagekcrisman ( 2017-10-27 11:39:50 -0600 )edit
1

Indeed, you need a Java runtime IIRC, and a way for Sage to find it which is currently missing. The tachyon viewer works though and should probably be set as the default (in fact I thought it was...)

Iguananaut gravatar imageIguananaut ( 2017-10-27 13:15:33 -0600 )edit

Sage is now using the Javascript version of Jmol, so there is no need for a Java runtime environment. Have you tried the threejs viewer?

sage: show(G,figsize=(5,5),title="Sample Figure",aspect_ratio=1, viewer='threejs')

Threejs should become at some point Sage's default 3D viewer. Contrary to Tachyon it is interactive and contrary to Jmol, it is fast and can render axes labels.

eric_g gravatar imageeric_g ( 2017-10-28 03:02:47 -0600 )edit