unexpected behaviors with Sage 8.0 on Mac

asked 2017-08-24 08:19:25 -0600

smbelcas gravatar image

updated 2017-08-24 10:57:11 -0600

I'm having some weirdnesses with my Sage 8.0 installation. I run Sage via the app, not the command line. Here's the story.

I upgraded to Sage 8.0. It made me create a folder to contain Jupyter notebooks. I found the menu item to upgrade notebooks individually. I picked my favorite and oldest notebook ("experiments") to upgrade. I ran a semi-arbitrary cell, which worked fine (mostly---it told me to install JDK, which I have installed so didn't install, and then Sage displayed the graphics properly). I created a couple of new cells. I saved the file.

This is where things get weird.

  • The converted/saved notebook isn't showing up in the default notebook list, which is empty even on refresh.
  • The converted/saved notebook isn't showing up in the Jupyter notebooks folder.

  • The Jupyter interface that opens automatically when I start Sage 8.0 is at localhost:8888.

  • The converted notebook was somewhere under localhost:8889.
  • I restarted everything (app, Jupyter server, upgrade server) and, because the converted notebook was nowhere to be found, I re-converted it and re-ran something in it. That's showing up as under localhost:8890.
  • Nothing showed up under the Running list for localhost:8888 until I created a new notebook there (which also appeared in all the other places I expected it to appear). The first converted notebook shows up under the Running list for localhost:8889. The second converted notebook shows up under the Running list for localhost:8890.

So... I can't tell whether I don't understand the new (Jupyter) paradigm, or whether something's gone wrong with my setup. How is saving/accessing/re-accessing converted notebooks supposed to work? What should I be doing differently?

Edited to add: The converted notebooks have been found (by accident): They ended up in my root directory instead of the default Jupyter directory. Still seems like things are not acting as they should.

edit retag flag offensive close merge delete

Comments

My guess is that the new port numbers (8890 etc.) are because you still have processes running on the previous ports. As a possible suggestion, try restarting the computer (or using the Terminal or Activity Monitor (in Utilities) or something to identify zombie Python processes and kill them).

kcrisman gravatar imagekcrisman ( 2017-08-24 08:56:26 -0600 )edit

Well, except no, the first thing I ran in 8.0 was a converted notebook. And that opened a new port with the conversion. I think that the conversion server is a separate server from regular Jupyter (there's some message about starting a new server). And that separate server is not using the same default location for Jupyter notebooks.

It seems like what's going on is that I need to - convert notebook - save notebook - quit everything - drag notebook into the correct directory - restart everything (haven't tried this yet) but still that doesn't seem to be how the conversion system should be designed---or if so, there ought to be a note on the conversion server page saying that this is what's going on.

smbelcas gravatar imagesmbelcas ( 2017-08-24 11:01:17 -0600 )edit

Again, that is certainly not how the system was designed, but apparently it isn't working right for you. Them ending up in the root directory is probably related to where you installed the Sage app? Unfortunately it's hard to remotely diagnose this sort of thing :(

kcrisman gravatar imagekcrisman ( 2017-08-24 12:02:19 -0600 )edit

If it's related to where I installed Sage.app, then this is a design flaw---I installed Sage.app in Applications, where (a) the instructions say to put it and (b) where my prior versions have been. Also, given that Sage 8.0 asks me to designate a default folder for Jupyter notebooks, one would think that that's where the notebooks would be saved independent of which server is being used.

smbelcas gravatar imagesmbelcas ( 2017-08-24 13:37:59 -0600 )edit

You are right but I'm just checking. I'm baffled on why the default save directory isn't being used.

kcrisman gravatar imagekcrisman ( 2017-08-25 09:05:14 -0600 )edit