Ask Your Question

no method available for opening http localhost 8000

asked 2016-06-20 15:46:31 +0200

JEFLSU gravatar image

I have built Sage 7.2 from source on a Red Hat machine, and when I try to start a notebook server, I get

/usr/bin/xdg-open: line 402: htmlview: command not found

/usr/bin/xdg-open: line 402: firefox: command not found

/usr/bin/xdg-open: line 402: mozilla: command not found

/usr/bin/xdg-open: line 402: netscape: command not found

/usr/bin/xdg-open: line 402: links: command not found

/usr/bin/xdg-open: line 402: lynx: command not found

xdg-open: no method available for opening 'http://localhost:8080?startup_token=a19cd71a527ae07b9d079e9e71c73c5a'

Now, I've looked at and but the machine is shared, so I don't want to go around messing with anything in /usr/bin. I don't have direct access (or ability to install an X-client on the physical machine I'm using), so I can't check there is a browser installed on the machine I put Sage on.

Is there a way to work around this just within Sage? I didn't see anything that answered this here in ask, or in Sage for Power Users. Perhaps I can't fix this without better access to the machine I put Sage on. In that case, I'll just have to run Sage from command line. But it's nice to have notebook access.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2016-06-20 16:52:30 +0200

slelievre gravatar image

updated 2016-06-20 17:03:14 +0200

Once you start the notebook server you can connect to it

  1. from the same machine, or
  2. from another machine.

I suppose your usecase is 1...

You can tell Sage which browser to use by setting the environment variable SAGE_BROWSER.

See the related question

You should try to figure out which web browsers are available on the machine you are using.

This list of Linux web browsers might help with that.

edit flag offensive delete link more


I've learned a bit more about the machine - it seems likely there are no browsers installed at all, it being a data server. I'll ask it which for the browsers in the list and see if I can get a hit, then try to set the default browser.

JEFLSU gravatar imageJEFLSU ( 2016-06-20 17:35:47 +0200 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2016-06-20 15:46:31 +0200

Seen: 4,357 times

Last updated: Jun 20 '16