Ask Your Question
1

jmol cannot run while plot3d

asked 2015-11-25 08:46:27 -0500

CXMA479 gravatar image

Well,the internet connection is terrible which makes me a mess... I downloaded the source(version 6.9 in Ubuntu 12.04).When I typed these following in sage command line,I got a problem...

g(x,y)=x^2+y
plot3d(g(x,y),(x,1,3),(y,1,10))

It said something about jmol,so I went to get jmol,then invoked it again,however didn't work.IT SAYS: RuntimeError: jmol cannot run, no suitable java version found
And I tried to call jmol in Terminal,it seemed to work well.
Does sage cann't find the right path?What should I do?

edit retag flag offensive close merge delete

Comments

Did you restart Sage after installing jmol?

A.P. gravatar imageA.P. ( 2015-11-30 10:07:22 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-11-25 10:59:11 -0500

slelievre gravatar image

updated 2018-03-01 04:56:09 -0500

I suggest visiting http://java.com/en/download/installed... to check if your Java is up-to-date.

Another useful trick is to plot using threejs instead of the default Jmol.

For this, you could do:

sage: g = lambda x, y: x^2 + y
sage: plot3d(g, (1, 3), (1, 10), viewer='threejs')
edit flag offensive delete link more
0

answered 2018-02-28 14:39:40 -0500

toricweb gravatar image

This is what I get it to work.

  1. Run

/usr/libexec/java_home -V

  1. Identify version 8 of Java, and remove the others using a command like

rm -rf /Library/Java/JavaVirtualMachines/jdk-9.0.1.jdk/

(with the version suitably changed; also you'll probably have to run this as sudo)

It turns out that JMol is incompatible with version 9, which I originally had. After getting rid of version 9, closing the shell session and restarting it, I am now able to plot 3d objects in Sagemath through JMol.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-11-25 08:46:27 -0500

Seen: 671 times

Last updated: Mar 01