Ask Your Question
0

Searching local HTML Docs with Chrome browser doesn't find anything, ever

asked 2013-05-14 03:01:54 -0500

rickhg12hs gravatar image

updated 2013-07-11 21:00:15 -0500

Using locally generated documentation ("make doc" in install dir), the Chrome browser search feature doesn't ever find anything. It used to work, but I don't know when it broke.

My local browser URLs:

file:///usr/local/src/sage/sage-5.9/devel/sage/doc/output/html/en/reference/search.html?q=lfsr

file:///usr/local/src/sage/sage-5.9/devel/sage-main/doc/output/html/en/reference/search.html?q=lfsr

... only show Searching ... forever.

This URL returns with doc references quickly.

http://www.sagemath.org/doc/reference...

What could be blocking my local doc searches? Where can I look to start debugging? Interestingly, Firefox works fine.

Chrome's javascript console reports:

Failed to load resource: Origin null is not allowed by Access-Control-Allow-Origin. file:///usr/local/src/sage/sage-5.10/devel/sage-main/doc/output/html/en/reference/searchindex.js
XMLHttpRequest cannot load file:///usr/local/src/sage/sage-5.10/devel/sage-main/doc/output/html/en/reference/searchindex.js. Origin null is not allowed by Access-Control-Allow-Origin.
edit retag flag offensive close merge delete

Comments

It works for me with sage-5.9.

tmonteil gravatar imagetmonteil ( 2013-05-14 06:00:29 -0500 )edit

@tmonteil: What URL do you use in your browser?

rickhg12hs gravatar imagerickhg12hs ( 2013-05-14 15:22:48 -0500 )edit

I used `file:///opt/sagemath/sage/devel/sage-main/doc/output/html/en/reference/search.html?q=lfsr` since sage-5.9 is installed at `/opt/sagemath/sage/` on my computer.

tmonteil gravatar imagetmonteil ( 2013-05-15 02:42:30 -0500 )edit

My Chrome still just sits there. No cpu or disk activity that I can see. However, just checked Firefox and it works! Must be a weird Chrome setting.

rickhg12hs gravatar imagerickhg12hs ( 2013-05-15 03:10:48 -0500 )edit

Same symptoms for Sage 5.10 and Chrome Version 28.0.1500.71 8-(

rickhg12hs gravatar imagerickhg12hs ( 2013-07-11 19:39:34 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-06-09 05:49:04 -0500

luran gravatar image

It appears that Chrome by default prevents local files from accessing other local files, and since you were viewing the documentation from a local file (through the file scheme), searchindex.js cannot be loaded as in your console report.

You can either start chrome with --allow-file-access-from-files option, or run a local server from the documentation directory (so that you visit it through the http protocol instead).

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-05-14 03:01:54 -0500

Seen: 719 times

Last updated: Jul 11 '13