Ask Your Question

DanielC's profile - activity

2017-08-01 11:25:49 -0600 received badge  Student (source)
2017-08-01 10:52:45 -0600 commented question Can't get typeset equations. No MathJax?

If it helps, https://drive.google.com/file/d/0B2jM6iLpC6htRTkwTTJsMldSdjA/view?usp=sharing (here is a screenshot)

2017-08-01 10:52:43 -0600 commented question Can't get typeset equations. No MathJax?

It's the Sage notebook. Not Jupyter, not CLI.

Typesetting is most definitely not working. I know that the MathJax files are there. I mentioned them in my post. But that doesn't change the fact that all my equations are just ASCII. There is also no error message.

Is there a way to use the Jupyter notebook? When I run sage -n jupyter, I don't see an option to switch to Maxima. I don't want to type %maxima on every single cell, of course.

2017-07-29 14:26:36 -0600 asked a question Can't get typeset equations. No MathJax?

I installed Sage yesterday on Ubuntu. I downloaded the latest version from the website. When I enter formulas I just get an ASCII text. I thought that Sage was supposed to use MathJax to produce nice-looking typset formulas, but I see nothing of the sort. I have spent a lot of time searching for a solution and found nothing. I recompiled Sage, but that made no difference. The Sage distribution seems to include MathJax,

% cd path/to/sage
% find . -name mathjax
./local/share/mathjax
./local/share/jupyter/nbextensions/mathjax
./local/lib/python2.7/site-packages/sagenb/data/mathjax
./build/pkgs/mathjax

I have looked through the documentation and through the UI and found nothing. Can someone please tell me what I need to do to make Sage look decent? I don't know if it matters, but I want to use Maxima. But the problem appears with the plain Sage backend too.

Cheers, Daniel.