Ask Your Question

elbeardmorez's profile - activity

2013-08-24 04:34:21 -0500 answered a question disable sage notebook password

using sage notebook 5.11

sage -c "notebook(secure=False, automatic_login=True)"

only landed me at the notebook's login page (so i initially thought the feature only by-passed some internal 'server'), but on trying another browser, i discovered that explicitly setting the browser via the SAGE_BROWSER environment variable gets this working as i'd hoped (i.e. straight through to the worksheet selection/create page and logged-in as 'admin')

SAGE_BROWSER=firefox sage -c "notebook(secure=False, automatic_login=True)"

possibly a bug then..