Ask Your Question

Revision history [back]

Some straightforward square root fractions are not simplified

I'm a Sage beginner who's trying to apply it to a set of equations I'm working on. In that process, I came across an issue where SageMath 9.4 is not simplifying some very straightforward square root fractions in my expressions. Let me show you a minimal example:

x = var('x')

$$-\frac{\sqrt{-x + 1}}{x - 1}$$

What I was expecting to get, of course, is $1 / \sqrt{1 - x}$. Calling simplify() or full_simplify() on the expression doesn't make a difference; I still get the same thing out. I experimented with other square root fractions as well to see if this issue recurs:







So in other words, Sage automatically simplifies all of the other expressions I tried in exactly the way that I would expect. To try out things a bit further, I tried to see if it helps to apply Sympy:

( sqrt(1-x)/(1-x) )._sympy_().simplify()


That works. (The simplify() argument is essential here; otherwise, the fraction is not automatically simplified.)

So, is there some subtle finesse here that I'm not understanding, or did I stumble across a bug in Sage's simplification algorithms?