Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Sagemath 8.3 for W10 setting working directory for notebook

Hi I wrote a comment in a post already open here: running-sagemath-82-natively-in-windows-how-to-change-the-jupyter-default-directory but as I'm not sure that my comment is read, I re-open a new post:

for the purpose of working in my "C:\Users\jean-pierre\Documents\SageMath\IPYNB directory" I put this line below in the file C:\Program Files\SageMath 8.3\runtime\etc\fstab.d

REM (initial) 8.3 C:\Users\jean-pierre /home/sage ntfs binary,posix=1,usr,acl 0 0
REM (initial) Old 8.2 C:\Users /home ntfs binary,posix=1,acl 0 0
C:\Users\jean-pierre\Documents\SageMath\IPYNB  /home/jean-pierre ntfs binary,posix=1,acl 0 0

but unfortunately that does not work as in fstab for 8.2, moreover the file fstab has been renamed fstab.d in 8.3. and the command executed from within the Sage Shell : sage-sethome "C:\Users\jean-pierre\Documents\SageMath\IPYNB" does not work too, despite I got the message :

Note: SAGE_ROOT=/opt/sagemath-8.3 (sage-sh) jean-pierre@ToshibaJPO:~$ sage-sethome "C:\Users\jean-pierre\Documents \SageMath\IPYNB" Sage home directory set to 'C:\Users\jean-pierre\Documents\SageMath\IPYNB' Close and restart all Sage sessions for the new setting to take effect.

I do not like to have the default working directory here :C:\Program Files\SageMath 8.3\runtime\home\sage