Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

package installed but cannot use

I want to use the spkg 'coxeter3', and I installed it successfully because it shows up under "installed_packages()".

Here's my code:

def MuL(C):
W = CoxeterGroup(C, implementation='coxeter3')
for u in W:
    U = (W(v) for v in W.bruhat_interval(u, W.long_element()))
    for v in U:
        ldiff = v.length()-u.length()-1
        if is_even(ld):
            p = W.kazhdan_lusztig_polynomial(u, v)
            if p[ld//2] != 0:
                List += [[u,v]]
return List

(ref: cannot post a link, but the code is copied from David Vogan)

I run' MuL(["A",4]) ' for example:

<ipython-input-11-10e92b1812f5> in <module>()

----> 1 MuL(["A",Integer(4)])

<ipython-input-10-cb3068dc75a6> in MuL(C)

1 def MuL(C):
----> 2     W = CoxeterGroup(C, implementation='coxeter3')
3     List=[]
4     for u in W:
5         U = (W(v) for v in W.bruhat_interval(u, W.long_element()))

/Applications/ in CoxeterGroup(data, implementation, base_ring, index_set)
    141             from sage.libs.coxeter3.coxeter_group import CoxeterGroup
    142         except ImportError:
--> 143             raise RuntimeError("coxeter3 must be installed")
    144         else:
    145             return CoxeterGroup(cartan_type)

RuntimeError: coxeter3 must be installed

what should I do to fix it?


mac os

spkg was installed not in terminal using (!sage -i coxeter3)

I used Jupiter to run the code but the same error appears using shell