Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Error when starting sage

I installed sage to: /home/groups/sc/modules/packages/sage/8.0/ (there are the subfolders bin/lib) on CentOS 7 Per module file, I set:

set root /home/groups/sc/modules/packages/sage/8.0

prepend-path PYTHONPATH $root/bin prepend-path LD_LIBRARY_PATH $root/lib prepend-path LIBRARY_PATH $root/lib prepend-path PATH $root/bin prepend-path CPATH $root/include

prepend-path SAGE_ROOT /home/groups/sc/modules/packages/sage/8.0/

However, when I try to start sage via "sage", I receive:

Error: SAGE_ROOT is set to a bad value: SAGE_ROOT=/home/groups/sc/modules/packages/sage/8.0/ You must correct it or erase it and run this script from the SAGE_ROOT or SAGE_ROOT/local/bin/ directory. Error setting environment variables by sourcing '/home/groups/sc/modules/packages/sage/8.0/bin/sage-env'; possibly contact sage-devel (see google/group/sage-devel).

I also tried to go to "cd /home/groups/sc/modules/packages/sage/8.0/bin" and "./sage", but this returns the same error message. If I do not set "SAGE_ROOT", I get the error, that SAGE_ROOT must be set.

What am I doing wrong? Thanks in advance.

Error when starting sage

I installed sage to: /home/groups/sc/modules/packages/sage/8.0/ (there are the subfolders bin/lib) on CentOS 7 Per module file, I set:

set  root  /home/groups/sc/modules/packages/sage/8.0

/home/groups/sc/modules/packages/sage/8.0

prepend-path PYTHONPATH $root/bin prepend-path LD_LIBRARY_PATH $root/lib prepend-path LIBRARY_PATH $root/lib prepend-path PATH $root/bin prepend-path CPATH $root/include

$root/include

prepend-path SAGE_ROOT /home/groups/sc/modules/packages/sage/8.0/

/home/groups/sc/modules/packages/sage/8.0/

However, when I try to start sage via "sage", I receive:

Error: SAGE_ROOT is set to a bad value:
 SAGE_ROOT=/home/groups/sc/modules/packages/sage/8.0/
You must correct it or erase it and run this script from the SAGE_ROOT
SAGE_ROOT or SAGE_ROOT/local/bin/ directory.
Error setting environment variables by sourcing '/home/groups/sc/modules/packages/sage/8.0/bin/sage-env';

possibly contact sage-devel (see google/group/sage-devel).

I also tried to go to "cd /home/groups/sc/modules/packages/sage/8.0/bin" and "./sage", but this returns the same error message. If I do not set "SAGE_ROOT", I get the error, that SAGE_ROOT must be set.

What am I doing wrong? Thanks in advance.

Error when starting sage

I installed sage to: /home/groups/sc/modules/packages/sage/8.0/ (there are the subfolders bin/lib) on CentOS 7 Per module file, I set:

set  root  /home/groups/sc/modules/packages/sage/8.0

prepend-path PYTHONPATH $root/bin
prepend-path LD_LIBRARY_PATH $root/lib
prepend-path LIBRARY_PATH $root/lib
prepend-path PATH  $root/bin
prepend-path CPATH  $root/include

prepend-path SAGE_ROOT /home/groups/sc/modules/packages/sage/8.0/

However, when I try to start sage via "sage", I receive:

Error: SAGE_ROOT is set to a bad value:

SAGE_ROOT=/home/groups/sc/modules/packages/sage/8.0/
You must correct it or erase it and run this script from the SAGE_ROOT or SAGE_ROOT/local/bin/ directory.
Error setting environment variables by sourcing '/home/groups/sc/modules/packages/sage/8.0/bin/sage-env';

possibly contact sage-devel (see google/group/sage-devel).

google/group/sage-devel).

I also tried to go to "cd /home/groups/sc/modules/packages/sage/8.0/bin" and "./sage", but this returns the same error message. If I do not set "SAGE_ROOT", I get the error, that SAGE_ROOT must be set.

What am I doing wrong? Thanks in advance.