Ask Your Question

Revision history [back]

Code stopped compiling out of nowhere for no apparent reason

Sage has all of a sudden stopped compiling my code. It happened seemingly out of nowhere and im getting very worried because i spent ALOT of time writing an algorithm. Basically nothing happens when i run the code the long grey line comes up with a green bar flashing and the normal output rectangle but it jsut stays in that state permanently. Nothing seems to fix the problem, i've tried going back in the history, copying and pasting to a new folder and worksheet changing the code, trying to get literally anything to compile but to no avail. Im literally dumbfounded at the moment.

Code stopped compiling out of nowhere for no apparent reason

Sage has all of a sudden stopped compiling my code. It happened seemingly out of nowhere and im getting very worried because i spent ALOT of time writing an algorithm. Basically nothing happens when i run the code the long grey line comes up with a green bar flashing and the normal output rectangle but it jsut stays in that state permanently. Nothing seems to fix the problem, i've tried going back in the history, copying and pasting to a new folder and worksheet changing the code, trying to get literally anything to compile but to no avail. Im literally dumbfounded at the moment.

EDIT: The green loading bar actually seems to be appearing at the top of the code when i try to compile. Also, I dont know if length is ever an issue with Sage Math worksheets but my code is 235 lines if that helps at all.

Code stopped compiling out of nowhere for no apparent reason

Sage has all of a sudden stopped compiling my code. It happened seemingly out of nowhere and im getting very worried because i spent ALOT of time writing an algorithm. Basically nothing happens when i run the code the long grey line comes up with a green bar flashing and the normal output rectangle but it jsut stays in that state permanently. Nothing seems to fix the problem, i've tried going back in the history, copying and pasting to a new folder and worksheet changing the code, trying to get literally anything to compile but to no avail. Im literally dumbfounded at the moment.

EDIT: The green loading bar actually seems to be appearing at the top of the code when i try to compile. Also, I dont know if length is ever an issue with Sage Math worksheets but my code is 235 lines if that helps at all.

EDIT 2: I am using SageMathCloud via. the link on sagemath.org, my web browser is google chrome, the code is written in a SageMath Worksheet, just in case my OS is Windows 10, here is a link to the code itself link text

Code stopped compiling out of nowhere for no apparent reason

Sage has all of a sudden stopped compiling my code. It happened seemingly out of nowhere and im getting very worried because i spent ALOT of time writing an algorithm. Basically nothing happens when i run the code the long grey line comes up with a green bar flashing and the normal output rectangle but it jsut stays in that state permanently. Nothing seems to fix the problem, i've tried going back in the history, copying and pasting to a new folder and worksheet changing the code, trying to get literally anything to compile but to no avail. Im literally dumbfounded at the moment.

EDIT: The green loading bar actually seems to be appearing at the top of the code when i try to compile. Also, I dont know if length is ever an issue with Sage Math worksheets but my code is 235 lines if that helps at all.

EDIT 2: I am using SageMathCloud via. the link on sagemath.org, my web browser is google chrome, the code is written in a SageMath Worksheet, just in case my OS is Windows 10, here is a link to the code itself link textProblematic Code.

Code stopped compiling out of nowhere for no apparent reason

Sage has all of a sudden stopped compiling my code. It happened seemingly out of nowhere and im getting very worried because i spent ALOT of time writing an algorithm. Basically nothing happens when i run the code the long grey line comes up with a green bar flashing and the normal output rectangle but it jsut stays in that state permanently. Nothing seems to fix the problem, i've tried going back in the history, copying and pasting to a new folder and worksheet changing the code, trying to get literally anything to compile but to no avail. Im literally dumbfounded at the moment.

EDIT: The green loading bar actually seems to be appearing at the top of the code when i try to compile. Also, I dont know if length is ever an issue with Sage Math worksheets but my code is 235 lines if that helps at all.

EDIT 2: I am using SageMathCloud via. the link on sagemath.org, my web browser is google chrome, the code is written in a SageMath Worksheet, just in case my OS is Windows 10, here is a link to the code itself Problematic Code.