Ask Your Question
0

how do I remove this sage installation problem

asked 2013-02-12 16:15:13 -0500

anonymous user

Anonymous

I have attempted to install sage on my ubuntu machine. Files are extracted properly and when I try to install by typing ./sage it first gives me hopes by saying:

"The Sage installation tree has moved from /home/meghak/Desktop/meghasage/sage-5.6-linux-32bit-ubuntu_12.04.1_lts-i686-Linux to /home/meghak/Desktop/meghasage/sage5.6 Updating various hardcoded paths... (Please wait at most a few minutes.) DO NOT INTERRUPT THIS.
Done updating paths."

but then it gives me a message "spkg/bin/sage: line 324:...local/bin/sage-ipython: Permission denied "

I looked into line 324 , it is indicated as ... in the following:

sage() { sage_setup sage-ipython "$@" -i }

Please help, it might be a trivial question but I am not getting it. Thanks in advance.

edit retag flag offensive close merge delete

Comments

1

What is the output of the following command (run it from the command prompt) ls -l /home/meghak/Desktop/meghasage/sage5.6/local/bin/sage-ipython

ppurka gravatar imageppurka ( 2013-02-12 17:42:44 -0500 )edit

To elaborate, you probably have the wrong permissions on some of your folders and aren't allowed to write/create a file somewhere.

kcrisman gravatar imagekcrisman ( 2013-02-13 03:26:54 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2013-02-13 09:54:11 -0500

Run Sage once as root:

sudo ./sage --nodotsage

This will give Sage the permissions it needs to update the paths. Afterwards, you will be able to run Sage as a normal user.

edit flag offensive delete link more

Comments

Is this anywhere in the installation doc? And is it safe if you are not the only user on a computer?

kcrisman gravatar imagekcrisman ( 2013-02-13 15:00:45 -0500 )edit

"sudo ./sage --nodotsage" did not work. I still have 'permission denied' message. I also checked i-python permissions, according to what ppurka suggested. I get "-rw-r--r-- 1".

Megha K. gravatar imageMegha K. ( 2013-02-13 21:03:42 -0500 )edit

@Megha - right. You are missing execute permissions. How did you miss out on execute permissions? I am pretty sure the downloaded Sage tarball has execute permissions in the required files. You can not go around fixing execute permissions file by file. There are too many files and not all of them should have this permission. I suggest you download the sage binary again. This time, be more careful and this time extract it with tar pxf downloaded_filename The 'p' in there should ensure that the extracted files have got the correct permissions. If you have the downloaded tar.lzma file, then you don't need to download that again. Simply run the above tar command.

ppurka gravatar imageppurka ( 2013-02-13 22:52:56 -0500 )edit

Thanks. I will do that.

Megha K. gravatar imageMegha K. ( 2013-02-14 16:45:51 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-02-12 16:15:13 -0500

Seen: 473 times

Last updated: Feb 13 '13