Ask Your Question
2

How to change default font-size in shift-click-created cells inside Sage Notebook?

asked 2013-01-15 23:36:06 -0500

anatematic gravatar image

updated 2013-01-16 09:02:26 -0500

To insert text with Latex in Sage Notebook we can create a special cell with a nice embedded text-editor by shift-clicking between two cells, but then the default font is really tiny compared to the one of the code. Change it every time is quite annoying. Any way to change it once and for all?

EDIT: I mean the default font size both in the output and in the editor while composing.

edit retag flag offensive close merge delete

Comments

Did you figure out the solution for increasing font size while composing?

NahsiN gravatar imageNahsiN ( 2015-03-02 15:55:52 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
3

answered 2013-01-16 04:19:46 -0500

ppurka gravatar image

updated 2013-01-16 04:20:19 -0500

You can create a file $HOME/.sage/notebook.css with the following content

.text_cell { font-size: 16px; }

Then restart your notebook. Change the font size to what you like of course.

edit flag offensive delete link more

Comments

Thank you! This solves half of the problem, the one about the output. I've edited my question, adding that I'm annoyed also by the size of the text in the editor itself.

anatematic gravatar imageanatematic ( 2013-01-16 09:04:03 -0500 )edit
1

I am not so sure about the content in the tinymce editor. I suspect it is controlled by the tinymce editor itself, and given what my searches came up with, one needs to [provide a custom css file](http://stackoverflow.com/questions/4427407/how-to-change-default-font-size-in-tinymce) during the init of the editor.

ppurka gravatar imageppurka ( 2013-01-16 18:04:30 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-01-15 23:36:06 -0500

Seen: 544 times

Last updated: Jan 16 '13