Ask Your Question
0

sage stopped working suddenly

asked 2012-06-12 22:58:46 -0500

ebs gravatar image

updated 2013-06-03 04:35:00 -0500

tmonteil gravatar image

I didn't do anything to the sage install.(I have upgraded by system yesterday) And suddenly today sage stopped working and this is being displayed.

/opt/sage/local/lib/libpython2.7.so.1.0(+0x10b0de)[0x7f38414160de]
/opt/sage/local/lib/libpython2.7.so.1.0(+0x10b353)[0x7f3841416353]
/opt/sage/local/lib/libpython2.7.so.1.0(+0x10b8bc)[0x7f38414168bc]
/opt/sage/local/lib/libpython2.7.so.1.0(PyImport_ImportModuleLevel+0x3a)[0x7f3841416e2a]
/opt/sage/local/lib/libpython2.7.so.1.0(+0xeb52f)[0x7f38413f652f]
/opt/sage/local/lib/libpython2.7.so.1.0(PyObject_Call+0x4e)[0x7f384135690e]
/opt/sage/local/lib/libpython2.7.so.1.0(PyEval_CallObjectWithKeywords+0x47)[0x7f38413f7ff7]
/opt/sage/local/lib/libpython2.7.so.1.0(PyEval_EvalFrameEx+0x1f1d)[0x7f38413fa49d]
/opt/sage/local/lib/libpython2.7.so.1.0(PyEval_EvalCodeEx+0x848)[0x7f38413fee68]
/opt/sage/local/lib/libpython2.7.so.1.0(PyEval_EvalCode+0x32)[0x7f38413fefa2]
/opt/sage/local/lib/libpython2.7.so.1.0(PyRun_FileExFlags+0xaa)[0x7f38414207ca]
/opt/sage/local/lib/libpython2.7.so.1.0(PyRun_SimpleFileExFlags+0xdb)[0x7f38414211fb]
/opt/sage/local/lib/libpython2.7.so.1.0(Py_Main+0xb82)[0x7f3841436342]
/lib/libc.so.6(__libc_start_main+0xf5)[0x7f3840673455]
python[0x4006b1]

------------------------------------------------------------------------
Unhandled SIGBUS: A bus error occurred in Sage.
This probably occurred because a *compiled* component of Sage has a bug
in it and is not properly wrapped with sig_on(), sig_off(). You might
want to run Sage under gdb with 'sage -gdb' to debug this.
Sage will now terminate.
------------------------------------------------------------------------
/opt/sage/spkg/bin/sage: line 671: 10989 Bus error               sage-notebook "$@"

I am using arch linux x86_64 running sage 5.0.1(manually compiled). How can I get it working again?

THis is the output of sage -gdb:

----------------------------------------------------------------------
| Sage Version 5.0, Release Date: 2012-05-14                         |
| Type notebook() for the GUI, and license() for information.        |
----------------------------------------------------------------------
/opt/sage/local/bin/sage-ipython
GNU gdb (GDB) 7.4.1
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-unknown-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /opt/sage/local/bin/python...(no debugging symbols found)...done.
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/libthread_db.so.1".
Python 2.7.2 (default, May 19 2012, 19:46:00) 
[GCC 4.7.0 20120505 (prerelease)] on linux3
Type "help", "copyright", "credits" or "license" for more information.

Program received signal SIGBUS, Bus error.
0x00007ffff30b674d in ?? ()
   from /opt/sage/local/lib/python2.7/lib-dynload/_ctypes.so
edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2012-06-13 01:00:31 -0500

ebs gravatar image

Along with sage, other programs in my system were also behaving wierdly and showing errors like /tmp/ folder is full even though that partition had > 200GB free.

I just cleared the folder /tmp/ (It has content of size 1.8 GB) and this problem is gone. Not sure how it works but, it worked!

edit flag offensive delete link more

Comments

1

Looks like your file system is damaged. Check smart data and make sure your backups are in order :-)

Volker Braun gravatar imageVolker Braun ( 2012-06-13 04:54:35 -0500 )edit
0

answered 2012-06-13 00:01:02 -0500

Volker Braun gravatar image

Did yesterday's upgrade pull in a new glibc version by any chance? Your best bet is probably to recompile Sage.

edit flag offensive delete link more

Comments

Actually glibc isn't there in the updates that were installed yesterday. I found out how to fix this problem. I"m going to post it as an answer.

ebs gravatar imageebs ( 2012-06-13 00:56:47 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-06-12 22:58:46 -0500

Seen: 273 times

Last updated: Jun 13 '12