Ask Your Question

5.12 command line startup looks odd

asked 2013-10-20 03:02:06 -0500

chexmix gravatar image

updated 2015-01-14 02:49:58 -0500

FrédéricC gravatar image

Hi --

I successfully built 5.12 on both my laptops last night (one is Slackware Linux 14.0 and the other is Slackware Linux -current). However, when I fire up Sage, what used to be a simple ascii box (hyphens etc) around the words

Sage Version 5.12, Release Date: 2013-10-07
Type "notebook()" for the browser-based notebook interface.
Type "help()" for help.

is now an ugly rectangle of 'sorry, I can't display this correctly' glyphs in my terminal.

I tried attaching a screen shot in case my words didn't suffice, but one apparently needs karma > 60 to do so.

As far as I can tell, this isn't affecting anything else (though I can't be sure it won't) so stands as more of annoyance ... but it sure is icky looking, and I'd love to know how to fix it.



edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted

answered 2013-10-20 03:25:29 -0500

vdelecroix gravatar image

updated 2013-10-20 03:26:05 -0500


It is because of that modification ticket 14733. What changes is that there are now some utf8 characters in the banner. It has been controversial and the related discussion may be found here.

A quick and dirty fix would be to modify the file sage-banner in the directory $SAGE_ROOT/local/bin/. It is simply a text file that is generated at the build time of Sage and that will be used each time you launch Sage.

Feel free to post a message on sage-devel saying that you are unhappy!

edit flag offensive delete link more



Thanks for your help! FWIW I have a dual boot netbook. I got the banner displaying correctly in xterm and in XFCE terminal on the Debian side but had no luck on the Slackware side ... so Googled a bit and found that Slackware exports LANG=en_US by default. I can switch to utf8 in the configuration file, though the same file contains a warning that this might cause some problems to be ... unhappy.

chexmix gravatar imagechexmix ( 2013-10-20 04:56:53 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2013-10-20 03:02:06 -0500

Seen: 137 times

Last updated: Oct 20 '13