Ask Your Question

Sage Notebook in Virtualbox Visible to Localhost but not LAN

asked 2012-04-17 14:48:58 +0200

lsimons gravatar image

I have been running the Sage Notebook VirtualBox VM happily for a while now, and would like to share the results within my LAN. I currently access Sage via http://localhost:8000, so the NAT port forwarding appears fine. However, I get "Unable to Connect" if I try http://my-computer-name:8000 or http://my-computer-ip:8000. I've tried allowing VirtualBox to open ports in the firewall settings.

I'm running Sage-4.7.1 in VirtualBox 4.0.10 on Windows 7 x64.

Thanks, Louis

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2012-04-17 15:02:21 +0200

Volker Braun gravatar image

updated 2012-04-17 15:03:30 +0200

Did you read the instructions at under "Giving Others Access to the Sage Virtual Machine"? They should spell out what you need step-by-step.

It is intentional that, by default, only the local computer user can connect to the virtual machine.

edit flag offensive delete link more


Sorry. I had convinced myself it was a VirtualBox configuration and had forgotten to check the Sage docs. That's embarassing. I modified the .bash_profile to start in secure mode with logins, and that worked fine at https://localhost:8000. However, when I change the network adapter to Bridged Adapter, sage fails to start with "Can't check status of PID 1299 from pidfile /home/sage.sage/sage_notebook.sagenb/ Operation not permitted".

lsimons gravatar imagelsimons ( 2012-04-17 15:43:57 +0200 )edit

Once you configure for Bridged Adpater, then look-up the assigned IP of the sage VM via ifconfig (alt+f1) to get to the terminal login. Then access the VM via https://my-vm-ip:8000 on the network.

lsimons gravatar imagelsimons ( 2012-04-17 15:54:16 +0200 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2012-04-17 14:48:58 +0200

Seen: 1,292 times

Last updated: Apr 17 '12