Ask Your Question
2

sagetex after upgrade to sage 4.7.2

asked 2011-11-05 08:46:35 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

Dear sage support group,

Let me start by thanking you for the recent advice which made it possible to use SageTeX with sage 4.7.1. I am so happy that I can use that.

However, after I upgraded to the new version of sage, sage 4.7.2, I can't get SageTeX to work again. I can't figure out what's wrong, and would greatly appreciate any help you might be able to give.

Here is what I did after installing sage 4.7.2 (app-version under Mac OS 10.6.8). The analogous setup worked for sage 4.7.1:
I copied the new version of the sagetex.sty-file coming with sage 4.7.2 to the folder ~/Library/texmf/tex/generic/sagetex/ and updated the call of sage in the sage.engine of TeXShop (the path to the application is correct, because it will start sage in a Terminal session).

With the new setup, according to the log file of TeXShop, sage is called when running the sage.engine of TeXShop, but still none of the output sage should produce for the example.tex-file provided is shown. Instead there are question marks. As might be expected one gets also lots of LaTeX warnings about undefined references.

What could be the problem?

Regards,

Udo Baumgartner

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
4

answered 2011-11-13 12:22:20 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

The names of the files generated by sagetex are xxx.sagetex.sage and xxx.sagetex.sout but sage.engine in TexShop is looking for xxx.sage and xxx.sout.

Modifying sage.engine in TexShop by changing sagename and soutname from

{filename/%tex/sage} and {filename/%tex/sout}

to

{filename/%tex/sagetex.sage} and {filename/%tex/sagetex.sout}

works for me.

phys

edit flag offensive delete link more

Comments

In my TeXShop, I had to change `set sagename = "${filename:r}.sage"` to `set sagename = "${filename:r}.sagetex.sage"`. So apparently there is no soutname anymore? Anyway, if someone has a different version of sage.engine this might be helpful.

kcrisman gravatar imagekcrisman ( 2012-01-26 04:55:48 -0500 )edit

I'm using TexShop 3.11. I think that when I got a new computer, with Mountain Lion, is when sagetex stopped working. I tried everything, to no avail. I even learned to run sage from the command line to process the .sage file. This is just what I needed, I'm a happy man again.

oscar231 gravatar imageoscar231 ( 2012-11-15 12:11:40 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-11-05 08:46:35 -0500

Seen: 301 times

Last updated: Nov 13 '11